## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preface</td>
<td>ix</td>
</tr>
<tr>
<td>Purpose</td>
<td>ix</td>
</tr>
<tr>
<td>Audience</td>
<td>ix</td>
</tr>
<tr>
<td>Organization of This Manual</td>
<td>ix</td>
</tr>
<tr>
<td>How to Use This Manual</td>
<td>x</td>
</tr>
<tr>
<td>Typographical Conventions</td>
<td>xi</td>
</tr>
<tr>
<td>Syntax Notation</td>
<td>xii</td>
</tr>
<tr>
<td>Progress Messages</td>
<td>xv</td>
</tr>
<tr>
<td>Other Useful Documentation</td>
<td>xvii</td>
</tr>
<tr>
<td>Getting Started</td>
<td>xvii</td>
</tr>
<tr>
<td>Development Tools</td>
<td>xviii</td>
</tr>
<tr>
<td>Reporting Tools</td>
<td>xix</td>
</tr>
<tr>
<td>4GL</td>
<td>xx</td>
</tr>
<tr>
<td>Database</td>
<td>xx</td>
</tr>
<tr>
<td>DataServers</td>
<td>xxi</td>
</tr>
<tr>
<td>SQL-89/Open Access</td>
<td>xxi</td>
</tr>
<tr>
<td>SQL-92</td>
<td>xxi</td>
</tr>
<tr>
<td>Deployment</td>
<td>xxii</td>
</tr>
<tr>
<td>WebSpeed.</td>
<td>xxiii</td>
</tr>
<tr>
<td>Reference</td>
<td>xxiii</td>
</tr>
</tbody>
</table>

1. **Results Overview** 1–1
   1.1 Results Overview 1–2
   1.2 Database Basics 1–2
      1.2.1 The Structure of a Table 1–4
   1.3 Indexes 1–6
   1.4 Table Relationships 1–7
      1.4.1 Types of Relationships 1–8
## Contents

### 2. Results Basics ........................................ 2–1
   2.1 Modified Versions of Results .......................... 2–2
   2.2 How Results Can Put Your Information to Work for You........ 2–2
   2.3 Starting Results ........................................ 2–3
      2.3.1 Starting Results from a Program Group............. 2–3
      2.3.2 Starting Results from the ADE Desktop............. 2–4
   2.4 The Results Main Window ............................... 2–6
   2.5 Getting Online Help .................................... 2–7
      2.5.1 Using the Online Help System ....................... 2–7
      2.5.2 Quitting Help ....................................... 2–9
   2.6 Exiting Results ......................................... 2–10

### 3. Query Basics ........................................... 3–1
   3.1 Creating a Query ........................................ 3–2
      3.1.1 Record Displays in Multi-table Queries ............. 3–7
   3.2 Saving a Query .......................................... 3–9
   3.3 Closing a Query ......................................... 3–10
   3.4 Opening an Existing Query .............................. 3–10
   3.5 Getting Query Information .............................. 3–11
   3.6 Printing Queries ........................................ 3–11
      3.6.1 Using Print Preview ................................. 3–11
   3.7 Deleting a Query ........................................ 3–13

### 4. Using Query Views ..................................... 4–1
   4.1 Query Views ............................................ 4–2
   4.2 Browse View ............................................. 4–2
      4.2.1 Navigating Through Records ......................... 4–3
      4.2.2 Using Frames ....................................... 4–4
      4.2.3 Modifying Frame Properties ........................ 4–5
   4.3 Form View ................................................ 4–6
      4.3.1 Navigating Through Records ......................... 4–7
      4.3.2 Modifying Records .................................. 4–7
      4.3.3 Rearranging Fields ................................. 4–10
      4.3.4 Using Frames ....................................... 4–11
      4.3.5 Modifying Frame Properties ........................ 4–12
   4.4 Report View ............................................. 4–13
      4.4.1 Adding Cover and Final Pages, Headers, and Footers... 4–14
      4.4.2 Selecting Page Sizes ................................. 4–18
      4.4.3 Adjusting Report Dimensions ......................... 4–19
      4.4.4 Printing Reports .................................... 4–20
   4.5 Label View ............................................... 4–20
      4.5.1 Selecting Label Types ................................ 4–24
      4.5.2 Modifying Label Formats ............................ 4–24
      4.5.3 Printing Labels ..................................... 4–26
B. Comparison Operators ................................................. B–1

Glossary ........................................................................... Glossary–1

Index ................................................................................... Index–1
## Figures

| Figure 1–1: | Paper Filing System Compared to a Database | 1–3 |
| Figure 1–2: | Relationship Between a Database and Its Tables | 1–4 |
| Figure 1–3: | Fields and Records in the Customer Table | 1–5 |
| Figure 1–4: | Structure of a Field | 1–5 |
| Figure 1–5: | Simple and Compound Indexes | 1–6 |
| Figure 1–6: | Relationship Between Customer and Order Tables | 1–7 |
| Figure 1–7: | One-to-one Relationships | 1–8 |
| Figure 1–8: | One-to-many Relationships | 1–8 |
| Figure 1–9: | Many-to-many Relationships | 1–9 |
Tables

Table 2–1: Query Views ................................................................. 2–2
Table 3–1: Query Views ............................................................... 3–2
Table 4–1: Browse View Keys ..................................................... 4–3
Table 4–2: Report Variable Functions ........................................... 4–17
Table 4–3: Custom Page Attributes ............................................. 4–19
Table 4–4: Custom Label Attributes ............................................ 4–25
Table 4–5: Custom Export Attributes .......................................... 4–30
Table 4–6: Code Formats ............................................................. 4–31
Table 6–1: Calculated Fields ....................................................... 6–6
Table 6–2: String Functions ........................................................ 6–18
Table 6–3: Numeric Functions ..................................................... 6–22
Table 6–4: Date Functions .......................................................... 6–25
Table 6–5: Logical Functions ...................................................... 6–30
Table 7–1: Field Properties ......................................................... 7–3
Table 7–2: Character Field Properties ......................................... 7–6
Table 7–3: Date Field Properties ................................................ 7–7
Table 7–4: Decimal and Integer Field Properties ......................... 7–9
Table A–1: Query Menu ............................................................. A–2
Table A–2: Table Menu ............................................................... A–3
Table A–3: Field Menu ............................................................... A–3
Table A–4: Data Menu ............................................................... A–4
Table A–5: Options Menu ........................................................... A–5
Table A–6: View Menu ............................................................... A–6
Table A–7: Help Menu ............................................................... A–7
Table B–1: Operators ................................................................. B–2
Preface

Purpose

This guide introduces you to Progress Results. Results is an interactive, menu-driven tool that lets you query, report, and maintain information stored in Progress-supported databases.

Audience

This guide is an end-user manual that explains how to use the default Results application. If you purchased Results through a third-party application vendor, the vendor might have modified Results. These modifications might include adding or removing features, or even incorporating Results into another application. If you have a modified Results application, your vendor might modify the help system to reflect these changes or provide you with additional documentation.

Organization of This Manual

Chapter 1, “Results Overview”

Briefly describes the benefits of using Results, then explains basic database concepts.

Chapter 2, “Results Basics”

Explains how to start and stop Results and use the online help system.

Chapter 3, “Query Basics”

Explains how to use Results to query information in a database, then print and save your queries.
Chapter 4, “Using Query Views”

Explains how to use the browse, form report, label, and export query views to process and analyze data.

Chapter 5, “Changing the Query Selection Criteria”

Explains how to change or refine the set of information a query retrieves from a database.

Chapter 6, “Analyzing Data”

Explains how to use calculated field, totals, and subtotals to analyze data.

Chapter 7, “Modifying Display Fields”

Explains how to add and remove display fields and change display field properties.

Appendix A, “Results Menus”

Describes the Results menus.

Appendix B, “Comparison Operators”

Describes the comparison operators you can use in a WHERE clause.

“Glossary”

How to Use This Manual

You need not read the entire manual in detail. A good strategy might be to skim through once quickly, then go back and read for detail only those chapters relevant to your situation and needs.
Typographical Conventions

This manual uses the following typographical conventions:

- **Bold typeface** indicates:
  - Commands or characters that the user types
  - That a word carries particular weight or emphasis

- **Italic typeface** indicates:
  - Progress variable information that the user supplies
  - New terms
  - Titles of complete publications

- **Monospaced typeface** indicates:
  - Code examples
  - System output
  - Operating system filenames and pathnames

The following typographical conventions are used to represent keystrokes:

- Small capitals are used for Progress key functions and generic keyboard keys.

  END-ERROR, GET, GO
  ALT, CTRL, SPACEBAR, TAB

- When you have to press a combination of keys, they are joined by a dash. You press and hold down the first key, then press the second key.

  CTRL-X

- When you have to press and release one key, then press another key, the key names are separated with a space.

  ESCAPE H
  ESCAPE CURSOR-LEFT
Syntax Notation

The syntax for each component follows a set of conventions:

- Uppercase words are keywords. Although they are always shown in uppercase, you can use either uppercase or lowercase when using them in a procedure.

In this example, ACCUM is a keyword:

**SYNTAX**

```
ACCUM aggregate expression
```

- Italics identify options or arguments that you must supply. These options can be defined as part of the syntax or in a separate syntax identified by the name in italics. In the ACCUM function above, the *aggregate* and *expression* options are defined with the syntax for the ACCUM function in the *Progress Language Reference*.

- You must end all statements (except for DO, FOR, FUNCTION, PROCEDURE, and REPEAT) with a period. DO, FOR, FUNCTION, PROCEDURE, and REPEAT statements can end with either a period or a colon, as in this example:

```
FOR EACH Customer:
    DISPLAY Name.
END.
```

- Square brackets ([ ]) around an item indicate that the item, or a choice of one of the enclosed items, is optional.

In this example, STREAM *stream*, UNLESS-HIDDEN, and NO-ERROR are optional:

**SYNTAX**

```
DISPLAY [ STREAM stream ] [ UNLESS-HIDDEN ] [ NO-ERROR ]
```

In some instances, square brackets are not a syntax notation, but part of the language.
For example, this syntax for the INITIAL option uses brackets to bound an initial value list for an array variable definition. In these cases, normal text brackets ([ ]) are used:

**SYNTAX**

```
INITIAL [ constant [ , constant ] ... ]
```

**NOTE:** The ellipsis ( ... ) indicates repetition, as shown in a following description.

- Braces ( { } ) around an item indicate that the item, or a choice of one of the enclosed items, is required.

In this example, you must specify the items BY and expression and can optionally specify the item DESCENDING, in that order:

**SYNTAX**

```
{ BY expression [ DESCENDING ] }
```

In some cases, braces are not a syntax notation, but part of the language.

For example, a called external procedure must use braces when referencing arguments passed by a calling procedure. In these cases, normal text braces ( { } ) are used:

**SYNTAX**

```
{ &argument-name }
```

- A vertical bar ( | ) indicates a choice.

In this example, EACH, FIRST, and LAST are optional, but you can only choose one:

**SYNTAX**

```
PRESELECT [ EACH | FIRST | LAST ] record-phrase
```
In this example, you must select one of *logical-name* or *alias*:

**SYNTAX**

```plaintext
CONNECTED ( { logical-name | alias } )
```

- Ellipses ( ... ) indicate that you can choose one or more of the preceding items. If a group of items is enclosed in braces and followed by ellipses, you must choose one or more of those items. If a group of items is enclosed in brackets and followed by ellipses, you can optionally choose one or more of those items.

In this example, you must include two expressions, but you can optionally include more. Note that each subsequent expression must be preceded by a comma:

**SYNTAX**

```plaintext
MAXIMUM ( expression , expression [ , expression ] ... )
```

In this example, you must specify MESSAGE, then at least one of expression or SKIP, but any additional number of expression or SKIP is allowed:

**SYNTAX**

```plaintext
MESSAGE { expression | SKIP [ (n) ] } ... 
```

In this example, you must specify `include-file`, then optionally any number of `argument` or `&argument-name = "argument-value"`, and then terminate with `}`:

**SYNTAX**

```plaintext
{ include-file
[ argument | &argument-name = "argument-value" ] ... }
```

- In some examples, the syntax is too long to place in one horizontal row. In such cases, *optional* items appear individually bracketed in multiple rows in order, left-to-right and top-to-bottom. This order generally applies, unless otherwise specified. *Required* items also appear on multiple rows in the required order, left-to-right and top-to-bottom. In cases where grouping and order might otherwise be ambiguous, braced (required) or bracketed (optional) groups clarify the groupings.

xiv
In this example, WITH is followed by several optional items:

**SYNTAX**

```
WITH [ ACCUM max-length ] [ expression DOWN ]
[ CENTERED ] [ n COLUMNS ] [ SIDE-LABELS ]
[ STREAM-IO ]
```

In this example, ASSIGN requires one of two choices: either one or more of field, or one of record. Other options available with either field or record are grouped with braces and brackets. The open and close braces indicate the required order of options:

**SYNTAX**

```
ASSIGN {  { [ FRAME frame ]
            { field [ = expression ] } [ WHEN expression ]
            } . . .
       |  { record [ EXCEPT field . . . ] }
}
```

**Progress Messages**

Progress displays several types of messages to inform you of routine and unusual occurrences:

- Execution messages inform you of errors encountered while Progress is running a procedure (for example, if Progress cannot find a record with a specified index field value).

- Compile messages inform you of errors found while Progress is reading and analyzing a procedure prior to running it (for example, if a procedure references a table name that is not defined in the database).

- Startup messages inform you of unusual conditions detected while Progress is getting ready to execute (for example, if you entered an invalid startup parameter).
After displaying a message, Progress proceeds in one of several ways:

- Continues execution, subject to the error-processing actions that you specify, or that are assumed, as part of the procedure. This is the most common action taken following execution messages.

- Returns to the Progress Procedure Editor so that you can correct an error in a procedure. This is the usual action taken following compiler messages.

- Halts processing of a procedure and returns immediately to the Procedure Editor. This does not happen often.

- Terminates the current session.

Progress messages end with a message number in parentheses. In this example, the message number is 200:

```
** Unknown table name table. (200)
```

Use Progress online help to get more information about Progress messages. Many Progress tools include the following Help menu options to provide information about messages:

- Choose Help→Recent Messages to display detailed descriptions of the most recent Progress message and all other messages returned in the current session.

- Choose Help→Messages, then enter the message number to display a description of any Progress message. (If you encounter an error that terminates Progress, make a note of the message number before restarting.)

- In the Procedure Editor, press the HELP key (F2 or CTRL-W).
Other Useful Documentation

This section lists Progress Software Corporation documentation that you might find useful. Unless otherwise specified, these manuals support both Windows and Character platforms and are provided in electronic documentation format on CD-ROM.

Getting Started

*Progress Electronic Documentation Installation and Configuration Guide* (Hard copy only)

A booklet that describes how to install the Progress EDOC viewer and collection on UNIX and Windows.

*Progress Installation and Configuration Guide Version 9 for UNIX*

A manual that describes how to install and set up Progress Version 9.1 for the UNIX operating system.

*Progress Installation and Configuration Guide Version 9 for Windows*

A manual that describes how to install and set up Progress Version 9.1 for all supported Windows and Citrix MetaFrame operating systems.

*Progress Version 9 Product Update Bulletin*

A guide that provides a brief description of each new feature of the release. The booklet also explains where to find more detailed information in the documentation set about each new feature.

*Progress Application Development Environment — Getting Started* (Windows only)

A practical guide to graphical application development within the Progress Application Development Environment (ADE). This guide includes an overview of the ADE and its tools, an overview of Progress SmartObject technology, and tutorials and exercises that help you better understand SmartObject technology and how to use the ADE to develop applications.

*Progress Language Tutorial for Windows* and *Progress Language Tutorial for Character*

Platform-specific tutorials designed for new Progress users. The tutorials use a step-by-step approach to explore the Progress application development environment using the 4GL.
Progress Master Glossary for Windows and Progress Master Glossary for Character (EDOC only)

Platform-specific master glossaries for the Progress documentation set. These books are in electronic format only.

Progress Master Index and Glossary for Windows and Progress Master Index and Glossary for Character (Hard copy only)

Platform-specific master indexes and glossaries for the Progress hard-copy documentation set.

Progress Startup Command and Parameter Reference

A reference manual that describes the Progress startup commands and parameters in alphabetical order.

Welcome to Progress (Hard copy only)

A booklet that explains how Progress software and media are packaged. An icon-based map groups the documentation by functionality, providing an overall view of the documentation set. Welcome to Progress also provides descriptions of the various services Progress Software Corporation offers.

Development Tools

Progress ADM 2 Guide

A guide to using the Application Development Model, Version 2 (ADM 2) application architecture to develop Progress applications. It includes instructions for building and using Progress SmartObjects.

Progress ADM 2 Reference

A reference for the Application Development Model, Version 2 (ADM 2) application. It includes descriptions of ADM 2 functions and procedures.

Progress AppBuilder Developer’s Guide (Windows only)

A programmer’s guide to using the Progress AppBuilder visual layout editor. AppBuilder is a Rapid Application Development (RAD) tool that can significantly reduce the time and effort required to create Progress applications.

Progress Basic Database Tools (Character only; information for Windows is in online help)

A guide for the Progress Database Administration tools, such as the Data Dictionary.
Progress Basic Development Tools (Character only; information for Windows is in online help)
A guide for the Progress development toolset, including the Progress Procedure Editor and
the Application Compiler.

Progress Debugger Guide
A guide for the Progress Application Debugger. The Debugger helps you trace and correct
programming errors by allowing you to monitor and modify procedure execution as it
happens.

Progress Help Development Guide (Windows only)
A guide that describes how to develop and integrate an online help system for a Progress
application.

Progress Translation Manager Guide (Windows only)
A guide that describes how to use the Progress Translation Manager tool to manage the
entire process of translating the text phrases in Progress applications.

Progress Visual Translator Guide (Windows only)
A guide that describes how to use the Progress Visual Translator tool to translate text
phrases from procedures into one or more spoken languages.

Reporting Tools
Progress Report Builder Deployment Guide (Windows only)
An administration and development guide for generating Report Builder reports using the
Progress Report Engine.

Progress Report Builder Tutorial (Windows only)
A tutorial that provides step-by-step instructions for creating eight sample Report Builder
reports.

Progress Report Builder User’s Guide (Windows only)
A guide for generating reports with the Progress Report Builder.

Progress Results Administration and Development Guide (Windows only)
A guide for system administrators that describes how to set up and maintain the Results
product in a graphical environment. This guide also describes how to program, customize,
and package Results with your own products. In addition, it describes how to convert
character-based Results applications to graphical Results applications.
4GL

Building Distributed Applications Using the Progress AppServer

A guide that provides comprehensive information about building and implementing distributed applications using the Progress AppServer. Topics include basic product information and terminology, design options and issues, setup and maintenance considerations, 4GL programming details, and remote debugging.

Progress External Program Interfaces

A guide to accessing non-Progress applications from Progress. This guide describes how to use system clipboards, UNIX named pipes, Windows dynamic link libraries, Windows dynamic data exchange, Windows ActiveX controls, and the Progress Host Language Call Interface to communicate with non-Progress applications and extend Progress functionality.

Progress Internationalization Guide

A guide to developing Progress applications for markets worldwide. The guide covers both internationalization—writing an application so that it adapts readily to different locales (languages, cultures, or regions)—and localization—adapting an application to different locales.

Progress Language Reference

A three-volume reference set that contains extensive descriptions and examples for each statement, phrase, function, operator, widget, attribute, method, and event in the Progress language.

Progress Programming Handbook

A two-volume handbook that details advanced Progress programming techniques.

Database

Progress Database Design Guide

A guide that uses a sample database and the Progress Data Dictionary to illustrate the fundamental principles of relational database design. Topics include relationships, normalization, indexing, and database triggers.

Progress Database Administration Guide and Reference

This guide describes Progress database administration concepts and procedures. The procedures allow you to create and maintain your Progress databases and manage their performance.
DataServers

Progress DataServer Guides

These guides describe how to use the DataServers to access non-Progress databases. They provide instructions for building the DataServer modules, a discussion of programming considerations, and a tutorial. Each DataServer has its own guide, for example, the *Progress DataServer for ODBC Guide*, the *Progress DataServer for ORACLE Guide*, or the *Progress/400 Product Guide*.

MERANT ODBC Branded Driver Reference

The Enterprise DataServer for ODBC includes MERANT ODBC drivers for all the supported data sources. For configuration information, see the MERANT documentation, which is available as a PDF file in installation-path\odbc. To read this file you must have the Adobe Acrobat Reader Version 3.1 or higher installed on your system. If you do not have the Adobe Acrobat Reader, you can download it from the Adobe Web site at: http://www.adobe.com/prodindex/acrobat/readstep.html.

SQL-89/Open Access

*Progress Embedded SQL-89 Guide and Reference*

A guide to Progress Embedded SQL-89 for C, including step-by-step instructions on building ESQL-89 applications and reference information on all Embedded SQL-89 Preprocessor statements and supporting function calls. This guide also describes the relationship between ESQL-89 and the ANSI standards upon which it is based.

*Progress Open Client Developer's Guide*

A guide that describes how to write and deploy Java and ActiveX applications that run as clients of the Progress AppServer. The guide includes information about how to expose the AppServer as a set of Java classes or as an ActiveX server.

*Progress SQL-89 Guide and Reference*

A user guide and reference for programmers who use interactive Progress/SQL-89. It includes information on all supported SQL-89 statements, SQL-89 Data Manipulation Language components, SQL-89 Data Definition Language components, and supported Progress functions.
SQL-92

*Progress Embedded SQL-92 Guide and Reference*

A guide to Progress Embedded SQL-92 for C, including step-by-step instructions for building ESQL-92 applications and reference information about all Embedded SQL-92 Preprocessor statements and supporting function calls. This guide also describes the relationship between ESQL-92 and the ANSI standards upon which it is based.

*Progress JDBC Driver Guide*

A guide to the Java Database Connectivity (JDBC) interface and the Progress SQL-92 JDBC driver. It describes how to set up and use the driver and details the driver’s support for the JDBC interface.

*Progress ODBC Driver Guide*

A guide to the ODBC interface and the Progress SQL-92 ODBC driver. It describes how to set up and use the driver and details the driver’s support for the ODBC interface.

*Progress SQL-92 Guide and Reference*

A user guide and reference for programmers who use Progress SQL-92. It includes information on all supported SQL-92 statements, SQL-92 Data Manipulation Language components, SQL-92 Data Definition Language components, and Progress functions. The guide describes how to use the Progress SQL-92 Java classes and how to create and use Java stored procedures and triggers.

Deployment

*Progress Client Deployment Guide*

A guide that describes the client deployment process and application administration concepts and procedures.

*Progress Developer’s Toolkit*

A guide to using the Developer’s Toolkit. This guide describes the advantages and disadvantages of different strategies for deploying Progress applications and explains how you can use the Toolkit to deploy applications with your selected strategy.

*Progress Portability Guide*

A guide that explains how to use the Progress toolset to build applications that are portable across all supported operating systems, user interfaces, and databases, following the Progress programming model.
Preface

WebSpeed

*Getting Started with WebSpeed*

Provides an introduction to the WebSpeed Workshop tools for creating Web applications. It introduces you to all the components of the WebSpeed Workshop and takes you through the process of creating your own Intranet application.

*WebSpeed Developer’s Guide*

Provides a complete overview of WebSpeed and the guidance necessary to develop and deploy WebSpeed applications on the Web.

*WebSpeed Installation and Configuration Guide*

Provides instructions for installing WebSpeed on Windows and UNIX systems. It also discusses designing WebSpeed environments, configuring WebSpeed Brokers, WebSpeed Agents, and the NameServer, and connecting to a variety of data sources.

*WebSpeed Version 3 Product Update Bulletin*

A booklet that provides a brief description of each new feature of the release. The booklet also explains where to find more detailed information in the documentation set about each new feature.

*Welcome to WebSpeed! (Hard copy only)*

A booklet that explains how WebSpeed software and media are packaged. *Welcome to WebSpeed!* also provides descriptions of the various services Progress Software Corporation offers.

Reference

*Pocket Progress* (Hard copy only)

A reference that lets you quickly look up information about the Progress language or programming environment.

*Pocket WebSpeed* (Hard copy only)

A reference that lets you quickly look up information about the SpeedScript language or the WebSpeed programming environment.
This chapter provides a brief overview of Results, and introduces you to the basic database concepts that are essential to understanding Results.

If you are already familiar with database concepts, you might want to skim this chapter before proceeding to Chapter 2, “Results Basics.”
1.1 Results Overview

In today’s fast-paced business environment, the amount of information you need to store, organize, and manage is growing daily. Progress Results works in conjunction with your Progress-supported database to help you sort, maintain, and analyze information quickly and efficiently. Results stops information overload and puts your information to work for you. You can use Results to update information stored in your database, create reports, generate mailing labels, or even export information from your database to common software applications, including spreadsheet and word processing packages.

1.2 Database Basics

A *database* is a collection of data organized in logically related tables that can be accessed or retrieved. A *table* is a collection of logically related records organized into rows and columns. One way to understand how a database works is to think of it as an electronic filing system because it organizes data in the same manner as a paper filing system.

When setting up a paper filing system, you keep all related information about a subject in a filing cabinet. The database equivalent to a filing cabinet is a table. Both a filing cabinet and a table allow you to group related information in one location. For example, in a paper filing system you might store information about customers in a filing cabinet called Customer. In a database, you store all this information in a Customer table.

How do you organize related information within a filing cabinet? By placing it in folders. In a database, a record functions as a folder. A *record* is a complete set of related information or *data*. For example, within the Customer filing cabinet, you would find folders for each customer. In the Customer table, you would find the records for each customer.
Figure 1–1 compares a paper filing system to a database filing system.

![Diagram of Paper Filing System Compared to a Database]

**Figure 1–1: Paper Filing System Compared to a Database**

For example, if you are running a business called All Around Sports, you might have a sales and inventory database that contains several tables for storing information about your customers, the products they have ordered, and your overall product inventory.
Figure 1–2 shows the database for All Around Sports.

Figure 1–2:  Relationship Between a Database and Its Tables

1.2.1  The Structure of a Table

Another way you can think of a database table is to view it as a paper table that you use to organize and present data. A paper table is made up of rows and columns, and the intersection of each row and column contains one specific piece of data.

A database table is similar to a paper table, but the terminology differs a little. A row in a database table is called a record and a column is called a field.
Figure 1–3 shows a section of the Customer table.

<table>
<thead>
<tr>
<th>Cust Number</th>
<th>Name</th>
<th>Street</th>
</tr>
</thead>
<tbody>
<tr>
<td>101</td>
<td>Jones, Sue</td>
<td>2 Mill Ave.</td>
</tr>
<tr>
<td>102</td>
<td>Heinz, Dieter</td>
<td>12 Dudley St.</td>
</tr>
<tr>
<td>103</td>
<td>Lee, Sandy</td>
<td>45 School St.</td>
</tr>
<tr>
<td>104</td>
<td>Tan, Steve</td>
<td>77 Main St.</td>
</tr>
</tbody>
</table>

Figure 1–3: Fields and Records in the Customer Table

This section of the Customer table contains four records, and each record contains a complete set of information about one customer. In this example, each record contains a customer number, name, and street. These items are called fields.

A field contains two elements: the name of the field and the data stored in the field. Note that the name of the field is common to all the fields in the same column. However, the data contained within a field varies from record to record. For example, the data in the field Cust-Num ranges from 101 to 104. Figure 1–4 shows the structure of a field.

Figure 1–4: Structure of a Field

The field name and the type of data the field stores is determined when the table is created. The data can be entered as an initial value when the database is created or later when the database is used.
1.3 Indexes

The last component of a database is called an index. When you open the drawer of a filing cabinet and thumb through the tabs on the folders, you are using a kind of index. What is on the paper tab represents the information found in the folder. For example, you expect the tabs in the Customer filing cabinet to contain the name of the customer whose information is in that folder. Similarly, an electronic index is a component defined for a specific database table that serves as the basis for faster searching, sorting, or otherwise processing the records in that table.

In a database, an index is a list that contains a value for each record in the table. When you create an index, you choose the fields used to derive the index value for each record. For example, if you choose the Name field as an index, Progress creates an index for the Customer table that consists of a list of customer names, just like the list of tabs in the paper filing system.

A simple index is based on the value of one field, while a compound index is based on two or more fields. Figure 1–5 shows an example of a simple and a compound index.

![Simple and Compound Indexes](image-url)
1.4 Table Relationships

The most powerful advantage that a database has over a paper filing system is that it can process data based on the relationship between database tables. The relationship is based on shared data. As shown in Figure 1–6, the Customer record contains the customer number, name, and address fields. The Order record contains the customer number, order number, delivery date, etc. The Order table is related to the Customer table because they contain a common field: Customer No.

![Relationship Between Customer and Order Tables]

Figure 1–6: Relationship Between Customer and OrderTables

With relationships between the Customer and Order tables established, you can perform requests for information, called queries. For example, you can query the database to find:

- All the orders for a given customer
- All the customers whose orders are promised before November 23, 1993.
- The number of outstanding orders for each sales region. (The number of unshipped orders for each region.)

As you can see by the relationship between the Customer and Order tables, relationships between tables are based on standard business practices. These relationships are determined when the database is designed.
1.4.1  Types of Relationships

You can create three types of relationships among tables: one-to-one, one-to-many, many-to-many. The following sections describe these relationships.

One-to-one Relationship

A one-to-one relationship occurs when one record can relate to one and only one instance of a record in another table. For example, a business might decide to assign one office to exactly one employee. Thus, one employee can have only one office. The same business might also decide that a department can have only one manager. Thus, one manager can manage only one department. Figure 1–7 illustrates this relationship.

---

One-to-many Relationship

A one-to-many relationship occurs when one record can relate to multiple records in another table. For example, one customer can place many orders, one student can take many courses, and a sales representative can have many customer accounts. Figure 1–8 illustrates this relationship.

---

Figure 1–7: One-to-one Relationships

Figure 1–8: One-to-many Relationships
Many-to-many Relationship

A many-to-many relationship occurs when multiple records can relate to multiple records in another table. Likewise, those related records have many records in the first table. For example, an order can contain many items, and an item can appear in many different orders; an employee can work on many projects, and a project can have many employees working on it. Figure 1–9 illustrates this relationship.

Figure 1–9: Many-to-many Relationships
Results Basics

This chapter explains the basics of what Results is and how it helps you maintain and analyze information stored in your Progress-supported databases. Specifically, it discusses:

- Starting Results
- Accessing the Results main window
- Using a modified version of Results
- Getting online help
- Exiting Results
2.1 Modified Versions of Results

Your organization can purchase Results directly through Progress Software Corporation (PSC) or through a third-party application vendor. If you purchase Results through a third-party vendor, your vendor might modify Results. These modifications might include adding and removing features or even incorporating Results into another application.

This guide describes how to use the Results application that PSC ships. If you have a modified Results application, your vendor might modify the online help system to reflect these changes or provide you with additional documentation.

2.2 How Results Can Put Your Information to Work for You

Results is a software tool that allows you to create queries to search for specific data in one or more databases. Once the query accesses the data, you can use a variety of query views to display and update the data, generate reports and mailing labels, or export the data to other applications. Table 2–1 lists the available query views.

<table>
<thead>
<tr>
<th>View</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse</td>
<td>Lists records online in a tabular form similar to a spreadsheet. You can scroll forward and backward through the data.</td>
</tr>
<tr>
<td>Report</td>
<td>Creates multi-line and master-detail reports for printing. Provides calculated values and totals for thorough data analysis. You can control the formatting of the headers, footers, and page breaks.</td>
</tr>
<tr>
<td>Form</td>
<td>Allows you to view, update, add, and delete individual records in the database.</td>
</tr>
<tr>
<td>Label</td>
<td>Formats and prints records in a variety of label formats, including mailing and inventory labels.</td>
</tr>
<tr>
<td>Export</td>
<td>Formats records to export to other applications.</td>
</tr>
</tbody>
</table>

Results is flexible. Instead of presenting you with a predetermined set of queries, Results lets you define and save queries that suit your particular needs. You can query all the records in a particular table or you can query any number of fields in one or more related tables. If, for example, your database contains Customer and Order tables and these tables are related, you can instruct Results to find all the orders for each customer in the database.
Results provides you with a filter to refine the contents of your queries. For example, you can use a filter to refine the previous query to find all the orders for each customer in Massachusetts.

### 2.3 Starting Results

How you start Results depends on whether your application was modified by a third-party vendor. If your application was not modified, you will most likely start Results from the ADE Desktop. If your application was modified, you will most likely start it from within a program group or from within another application. The following sections describe how to start Results from a program group and from the ADE Desktop. If your Results application is contained within another application or you are not sure how to start Results, see your system administrator.

#### 2.3.1 Starting Results from a Program Group

Follow these steps to start Results from the Progress program group:

**NOTE:** Depending on how the Results application is configured, the names of the Progress program group and Results icons might be different.

1. Choose the Results icon from the ADE Desktop.

2. If you are starting Results for the first time, a dialog box prompts you to create the `.qc7` file. Choose Yes.

   The Progress Results window appears. If your Results application was modified, you might see additional startup screens before the Results main window appears.

**NOTE:** The query directory (.qc7) file contains descriptions to the filenames that Results generates.
2.3.2 Starting Results from the ADE Desktop

Follow these steps to start Results from the ADE Desktop:

**NOTE:** Depending on how the Results application is configured, the appearance of the ADE Desktop and Progress and Results icons might differ from their appearance in these instructions.

1. Double-click the Progress icon on your Windows desktop.

   The Progress ADE Desktop appears:

   ![Progress ADE Desktop](image)

   **NOTE:** The specific Progress product icons that display can vary, depending on the Progress products installed at your site.

2. Single-click the Results icon on the ADE Desktop.

3. If you’re starting Results for the first time, a dialog box prompts you to create the .qc7 file. Choose Yes.

4. If you are not connected to a database, the following dialog box appears:
5 ♦ Choose OK to connect to a database. The Connect Database dialog box appears:

![Connect Database Dialog Box](image)

6 ♦ Specify the connection information, then choose OK.

After you connect to a database, the Progress Results window appears. Note that if your Results application was modified, you might see additional startup screens before the Progress Results window appears.

**NOTE:** The query directory (.qc7) file contains descriptions to the filenames that Results generates.
2.4 The Results Main Window

Use the Results main window to create and open queries:

By default, the Progress Results window contains the following items:

- **Menu Bar**—Lets you access the menu options you use to run Results. See Appendix A, “Results Menus,” for a description of each menu.
- **Tool Bar**—Provides quick access to the most commonly used Results menu options.
- **Status Bar**—Contains informational messages about the current status of Results.
2.5 Getting Online Help

You can access help information from the Progress Desktop in the following ways:

- Press F1 to get information about the current window or dialog box. This is known as context-sensitive help.
- Use the Help menu to access information about Results

<table>
<thead>
<tr>
<th>Help</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help Topics</td>
<td>Choose this option to access the main table of contents, the index, and the search engine for help information about Results.</td>
</tr>
<tr>
<td>Messages</td>
<td>Choose this option to quickly search for information about Progress and operating system error messages. In the Messages dialog box, enter the message number to display the description.</td>
</tr>
<tr>
<td>Recent Messages</td>
<td>Choose this option to display the most recent Progress message and its description. You can scroll backwards through all messages since the beginning of your session.</td>
</tr>
<tr>
<td>About Results</td>
<td>Choose this option to display the most recent Progress message and its description. You can scroll backwards through all messages since the beginning of your session.</td>
</tr>
</tbody>
</table>

Once you are in the help system, a wealth of information is at your fingertips. The following section provides some basic information about how to use the help system.

2.5.1 Using the Online Help System

The information in the Results help system is organized into discrete units called help topics. A help topic typically contains information about one thing, such as a particular window or dialog box.

When you access the help system, the Progress Help Viewer displays a single help topic on the screen. You can also use the Help Viewer to display and navigate through other help topics.

The help system is hyper-text based, meaning you can click on underlined, colored text to access information about that topic. These special words and phrases are called hypertext links.
The following figure shows the Results Help that you can access from the main Progress Help window:

There are two types of links you can access; pop-up links and go-to links.

A pop-up link displays a definition when selected. For example, when you click the hypertext link “queries” in the help topic associated with the Results main window, the following definition appears:

**query**

A set of instructions that tells RESULTS to find the contents of one or more tables in your database. Creating a query consists of selecting the following:

- The view you want to use to process the information in Tables that comprise the query
- The query
- Fields you want to display

The pop-up definition overlays the original help topic. To dismiss the pop-up definition and return to the help topic, click anywhere in the window or press ESC.
A *go-to link* displays a new help topic. For example, when you choose the hypertext link “General Tasks” in the help topic associated with Results, the following subtopics appears.

From this topic, you can access other help topics.

As you can see, hypertext is a powerful information presentation and navigation tool. You can also use the Contents, Search, Back, and History buttons to create your own paths through the help system.

### 2.5.2 Quitting Help

To quit help, choose File→Exit in the help window.
2.6 Exiting Results

Follow these steps to exit Results.

1 ♦ Choose Query→ Exit.

   If you created or modified the query and did not save it, a dialog box prompts you to save your query.

2 ♦ Choose Yes to save the query or No to close the query without saving it.

   If you are saving the query for the first time, the Save As dialog box appears.

3 ♦ Type a description of your query that consists of up to 48 alphanumeric characters (A-Z, a-z, and 0-9), then choose OK.

   Be sure to pick a description that reflects the type of query you created. For example, you might type Customer for a query that accesses all the fields in the Customer table.
A *query* is a set of instructions that specifies the criteria by which information is extracted from a database. A query can retrieve data from one or more tables, from all the records in a table, or just a subset of records.

Once you have located the data you need, you can use a variety of sorting and filtering features to fine tune and analyze the data. For example, to send catalogs to your current customers only, you might create a query to locate the names and addresses of all your customers who ordered merchandise in the last year. Then you can use the query to generate mailing labels, create printed reports, update the information stored in the database, and even create a data file to export the data to another application.

This chapter explains the basics of creating and using queries as follows:

- Creating a Query
- Saving a Query
- Closing a Query
- Opening an Existing Query
- Getting Query Information
- Printing Queries
- Deleting a Query
3.1 Creating a Query

There are three steps to creating a query:

NOTE: The instructions in this guide are based on the Sports database shipped with the Results application. If you have access to this sample database, you can use it while you learn how to use Results.

1 ♦ Select the database tables to be included in the query.

When you create a query, you select the tables that contain the information you want Results to retrieve.

2 ♦ Select the view you want to use to process the information retrieved by the query.

A view is an on-screen display of only part of the information in a database, as specified in a query. A view can display data from one or more tables or from other views.

Table 3–1 lists these views.

Table 3–1: Query Views

<table>
<thead>
<tr>
<th>View</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse</td>
<td>Lists records online in a tabular format similar to a spreadsheet. You can scroll forward and backward through the data.</td>
</tr>
<tr>
<td>Report</td>
<td>Creates multi-line and master-detail reports for printing. Provides calculated values and totals. You can format the headers, footers, and page breaks.</td>
</tr>
<tr>
<td>Form</td>
<td>Allows you to view, update, add, and delete individual records in the database.</td>
</tr>
<tr>
<td>Label</td>
<td>Formats and prints records in a variety of label formats, including mailing and inventory labels.</td>
</tr>
<tr>
<td>Export</td>
<td>Formats records to export to other applications.</td>
</tr>
</tbody>
</table>
3 ♦ Select the fields you want to display.

When you create a query, Results retrieves all the fields in each table you include in the query. However, you might want to limit the number of display fields, which are the fields that you select to appear in the view, whether on-screen or printed. For example, if you create a query that accesses the Customer table, you might want to view only those fields that contain address information. Limiting the display fields does not alter the contents of the query; it simply limits the number of fields you view.

Once you create the initial query, you can modify its contents, select a new query view, or select different display fields.

Follow these steps to create a query:

**NOTE:** The steps for selecting the display fields do not apply to the Label view. See Chapter 4, “Using Query Views,” for instructions on creating queries for the Label view.

1 ♦ Choose Query→New and a view for the query. The Add/Remove Tables dialog box appears:

The Available Tables selection list shows the tables that comprise the database that you are connected to. If you are connected to more than one database, Results indicates the database in which each table resides.
2 ♦ Select a table from the Available Tables selection list, then choose Add. The table appears in the Selected Tables selection list. The Available Tables selection list now displays only tables that have a relationship with the table you selected:

![Add/Remove Tables](Image)

3 ♦ Repeat Step 2 to add more tables.

After you add tables, the Selected Tables selection list displays the relationships, or joins, among the tables in the query. For example, if you select the Customer, Order, and Order-Line tables, the Selected Tables selection list appears as follows:

![Add/Remove Tables](Image)

 Displays the table’s relationship with the preceding table in the list
4 ♦ When you are done adding tables, choose OK. The Add/Remove Fields dialog box appears:

![Add/Remove Fields dialog box]

*Indicates the table that contains the field*

The Available Fields selection list displays all the fields in the tables you selected. If you are connected to more than one database, Results indicates the database where each field in the list resides.

5 ♦ Select one or more fields from the Available Fields selection list, then choose Add:

![Add/Remove Fields dialog box]

To select multiple fields, press **CTRL** and click individual fields, or press **SHIFT** and drag the mouse to select a range of fields. The fields are displayed in the Selected Fields selection list in the order in which they will be displayed in the view (from left to right).

6 ♦ To reorder the display fields, select a field and choose the Move Up or Move Down button. Repeat this process until the fields are listed in the order in which you want them to appear in the view.
7 ♦ Choose OK to display the query in the Progress Results window.

The appearance of the query depends on the type of view you chose in Step 1. The following query illustrates the Browse view. See Chapter 4, “Using Query Views,” for more information about changing and using query views:

![Query Display](image)

The status bar identifies the query view you are using and the database to which you are connected. If you are connected to more than one database, the status bar lists the first database to which you connected.

Each record in the view contains the information from the display fields you selected for the query. In this example, the records are *composite records* because they contain fields from more than one table. The data is displayed from left to right in the order you specified when you created the query.

The customer Lift Line Skiing appears several times because of the type of relationships between the tables. Each customer can have one or more orders, thus the relationship between the Customer and Order tables is a one-to-many relationship. Each order can have several line items, so the Order and Order-Line tables also have a one-to-many relationship. Results displays a composite record for each line item a customer orders.

For more information about relationships, see Chapter 1, “Results Overview.”
3.1.1 Record Displays in Multi-table Queries

There are two defaults that determine how records are displayed in queries that contain two or more tables:

- **Sort order**—Uses the primary index in the first table you included in the query to determine the order in which Results retrieves records from the tables.

- **Relationship types**—Displays only those records that contain information in both tables.

The following sections explain these defaults.

**Sort Order Default**

When you create a query that contains more than one table, Results uses the primary index for the first table you included in the query to determine the order in which Results retrieves and displays the records. See Chapter 1, “Results Overview,” for more information about indexes.

You can change the order in which records are sorted by selecting one or more fields to control the sort order for the query. For more information, see Chapter 5, “Changing the Query Selection Criteria.”

**Relationship Types Default**

When you create a query that specifies a field that is contained in more than one table, by default Results retrieves only the records that contain data in the related fields.

<table>
<thead>
<tr>
<th>Customer Table</th>
<th>Order Table</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cust-Num</strong></td>
<td><strong>Order-Num</strong></td>
</tr>
<tr>
<td>1 Lift Line Skiing</td>
<td>6 1</td>
</tr>
<tr>
<td>2 Urpon Frisbee</td>
<td>21 4</td>
</tr>
<tr>
<td>3 Hoops Croquet Co.</td>
<td>55 3</td>
</tr>
<tr>
<td>4 Go Fishing Ltd.</td>
<td>94 2</td>
</tr>
<tr>
<td>5 Match Point Tennis</td>
<td>135 6</td>
</tr>
<tr>
<td>6 Fanatical Athletes</td>
<td></td>
</tr>
</tbody>
</table>

Notice that the Order table doesn’t contain any orders for Customer 5. Thus, a query to display the orders for each customer does not display a record for customer. This type of a relationship is called a *partial relationship*, or inner join.
The following sample query illustrates the results of a partial relationship between the Customer and Order tables.

<table>
<thead>
<tr>
<th>Cust-Num</th>
<th>Name</th>
<th>Order-Num</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Lift Line Skiing</td>
<td>6</td>
</tr>
<tr>
<td>2</td>
<td>Urpon Frisbee</td>
<td>94</td>
</tr>
<tr>
<td>3</td>
<td>Hoops Croquet Co.</td>
<td>55</td>
</tr>
<tr>
<td>4</td>
<td>Go Fishing Ltd.</td>
<td>21</td>
</tr>
<tr>
<td>6</td>
<td>Fanatical Athletes</td>
<td>135</td>
</tr>
</tbody>
</table>

If you want to display all the records in the Customer table whether or not the Order table contains a related record, you can change the type of relationship between the tables to a complete relationship, or an outer join. The following sample query illustrates the results of a complete relationship between the Customer and Order tables.

<table>
<thead>
<tr>
<th>Cust-Num</th>
<th>Name</th>
<th>Order-Num</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Lift Line Skiing</td>
<td>6</td>
</tr>
<tr>
<td>2</td>
<td>Urpon Frisbee</td>
<td>94</td>
</tr>
<tr>
<td>3</td>
<td>Hoops Croquet Co.</td>
<td>55</td>
</tr>
<tr>
<td>4</td>
<td>Go Fishing Ltd.</td>
<td>21</td>
</tr>
<tr>
<td>5</td>
<td>Match Point Tennis</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Fanatical Athletes</td>
<td>135</td>
</tr>
</tbody>
</table>

For details on how to change table relationships in multi-table queries, see Chapter 5, “Changing the Query Selection Criteria.”
3.2 Saving a Query

Once you create a query, you can save and reuse the query whenever you want to access the same information in your database. Follow these steps to save a query.

1 ♦ Choose Query→Save. The Save As dialog box appears:

2 ♦ Type a short description for the query.

   The description can consist of up to 48 alphanumeric characters and spaces. You’ll use the query description to locate and open queries, so pick a description that reflects the type of query you create. For example, you might type Customer Orders for a query that accesses all the orders for each customer in the Customer table.

   **NOTE:** Results lets you use descriptions to locate and access query files, so you are not limited to eight-character filenames. However, Results automatically generates filenames for these files so that your computer can store and access them properly. The query directory (.qd7) file contains a directory that maps the descriptions you provide with the actual filenames Results generates. See the Progress Results Administration and Development Guide for more information about the query directory.

3 ♦ Choose OK.

Once you have saved a query, you can use the Save As command to save the query without changing its description.
3.3 Closing a Query

Follow these steps to close a query without quitting Results

1 ♦ Choose Query→Close.

If you created or modified the query and did not save it, a dialog box prompts you to save.

2 ♦ Choose OK to save the query and close it, or No to close the query without saving it.

If you are saving the query for the first time, the Save As dialog box appears.

3 ♦ Type a description of your query that consists of up to 48 alphanumeric characters, then choose OK.

3.4 Opening an Existing Query

Follow these steps to open an existing query:

1 ♦ From the Results main window, choose Query→Open. The Open dialog box appears.

2 ♦ Select the query you want to open, then choose OK.

3 ♦ By default, this dialog box lists all the queries for databases to which you are currently connected. Although you cannot open queries for databases to which you are not currently connected, you can list them by selecting the Show Queries on Disconnected Databases toggle box.
3.5 Getting Query Information

To help you keep track of the contents of your queries, you can request Results to display a list containing the tables included in the query, the display fields used, the sort order for the query, and if you printed or viewed a report through print preview, the amount of time it took to run the report.

To display this list, choose Options→Query Information.

3.6 Printing Queries

You can print the contents of your queries from the Report, Labels, and Export query views. Follow these steps to print a query:

1♦ Choose Query→Print→To Printer. The MS-Windows Print dialog box appears.
2♦ Select the print settings you want to use, then choose OK.

3.6.1 Using Print Preview

Print Preview lets you display the query instead of sending it to the printer.

To use Print Preview, choose Query→Print Preview. The query appears in a Print Preview window.

You can use several techniques to scan through records in Print Preview, including the horizontal and vertical scroll bars, the navigation buttons, and PAGE UP and PAGE DOWN. The following sections describe these methods.
Scroll Bars
Use the vertical scroll bar to scan up and down through records on the current page. Use the horizontal scroll bar to scroll left and right to view information that is wider than the window.

Navigation Buttons
Use the navigation buttons listed here to change the current page displayed in the print preview.

Prompts for a page to display.

Displays the first page of records.

Displays the previous page of records.

Displays the next page of records.

Displays the final page of records.

Keyboard
Before you can use the keyboard to navigate in Print Preview, click anywhere inside the preview to give it focus.

Results provides the following navigation keys:

- **Page Up**—Scrolls up through the current page one screen at a time.
- **Page Down**—Scrolls down through the current page one screen at a time.
- **Cursor Up**—Scrolls to the previous record on the page.
- **Cursor Down**—Scrolls to the next record on the page.
3.7 Deleting a Query

Follow these steps to delete one or more queries:

1 ♦ Choose Query→Delete. The Delete dialog box appears.

2 ♦ Choose the query you want to delete, then choose OK.

To select multiple queries, press CTRL and click individual queries, or press SHIFT and drag the mouse to select a range of queries:

3 ♦ By default, this dialog box lists all the queries for databases that you are currently connected to. To list additional queries for databases that you are not currently connected to, activate the Show Queries on the Disconnected Databases toggle box.
Results provides query views that process and analyze data. This chapter describes the following types of query views:

- Browse
- Form
- Report
- Label
- Export
4.1 Query Views

You can display queries in a variety of interchangeable views that let you accomplish specific tasks. These views include Browse, Form, Report, Label, and Export. To change the view, either choose a different view from the View menu or choose a view button from the tool bar. For example, if you are currently viewing a query as a browse, you might want to change it to a report that you can format and print.

When you switch between views, Results maintains both the contents of the query and the display fields you selected, so none of your data is lost. However, the Labels view allows you to select an additional set of display fields specifically for creating labels. In this case, Results maintains two lists of display fields: the list you select for creating labels and the list you use for the remaining query views. Results automatically toggles between the two lists depending on the view you choose. See the “Label View” section for more information about switching to the Label view.

4.2 Browse View

A browse is an on-screen view that displays records in a tabular format similar to a spreadsheet. You can use a browse view to scan through large numbers of records quickly. The following figure shows an example of a browse:

The query in this browse uses a relationship among the Customer, Order, and Order-Line tables to list the items each customer ordered. Each composite record displays the Cust-Num and Name fields from the Customer table; the Order-num field from the Order table, and the Item-num and Extended-Price fields from the Order-Line table.
4.2.1 Navigating Through Records

Use the Left and Right arrow buttons and the vertical scroll bar to scan through records. The Left arrow button scrolls to the first record in the browse and selects it, and the Right arrow button scrolls to the last record in the browse and selects it. If the browse is wider than the window, a horizontal scroll bar appears so that you can scroll left or right.

You can also use several keyboard keys to navigate through records in the browse view. To use a key, move the input focus to the browse by placing the pointer in the browse and clicking the left mouse button, then press one of the keys described in Table 4–1.

Table 4–1: Browse View Keys

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Up</td>
<td>Scrolls to the first record in the window and selects it.</td>
</tr>
<tr>
<td>Page Down</td>
<td>Scrolls to the last record in the window and selects it.</td>
</tr>
<tr>
<td>Home</td>
<td>Scrolls to the first record in the browse and selects it.</td>
</tr>
<tr>
<td>End</td>
<td>Scrolls to the last record in the browse and selects it.</td>
</tr>
<tr>
<td>Cursor Up</td>
<td>Scrolls up one record in the browse and selects it.</td>
</tr>
<tr>
<td>Cursor Down</td>
<td>Scrolls down one record in the browse and selects it.</td>
</tr>
</tbody>
</table>
4.2.2 Using Frames

The query is contained within a portion of the window called a frame. By default, a browse uses one frame for each query you create:

If a query includes more than one table, you can tell Results to split the contents of the tables into two frames, allowing you to view the data more easily. For more information, see the “Using Master and Detail Sections to Display Records” section in Chapter 6, “Analyzing Data.”
The following example illustrates a browse query that uses two frames:

When you split the contents of a query into two frames, Results provides a set of navigation buttons for each frame. The frames will overlap if there is not enough space to display them in the window at the same time. To display both frames simultaneously, modify the frame properties as described below.

You can also enlarge the window by clicking the maximize button or dragging the corner resize handle in the window border.

### 4.2.3 Modifying Frame Properties

Follow these steps to modify the properties for one or both frames to adjust their position and size:

1. Choose Options→Frame Properties. The Frame Properties dialog box appears:
Select the frame you want to modify from the Frames selection list.

Change one or both of the following attributes:

- **Row**—Determines how many rows separate the menu line from the top of the frame. Use this feature to stagger the location of the frames when you want to display two frames simultaneously.

- **Browse Height**—Determines the number of records displayed in a query at one time.

Choose OK.

### 4.3 Form View

A *form* is an on-screen view that displays one record at a time. You typically use forms to add, delete, and update one or more records in a table. The following figure shows an example of a form:

This form displays records in the Customer table one at a time. Press **TAB** to move through the display fields within the record.
4.3.1 Navigating Through Records

Use the navigation buttons to scan through records:

 Displays the first record in the query.

 Displays the previous record in the query.

 Displays the next record in the query.

 Displays the final record in the query.

4.3.2 Modifying Records

You can use forms to update, copy, add, and delete records contained in a single table.

For example, if a query consists of the fields in the Customer table, you can use the Form view to modify the Customer table. However, if a query consists of fields from more than one table, you cannot modify the tables unless you use the Master-Detail feature to break the tables into individual frames. For more information, see the “Using Master and Detail Sections to Display Records” section in Chapter 6, “Analyzing Data.”

The following sections explain how to modify records contained within a single table.
Updating Records

Follow these steps to change the contents of one or more fields in a record:

1 ♦ Display the record you want to modify.

2 ♦ Choose the Update button.

Results displays the fields in the Update window. The first field is highlighted by default:

3 ♦ Select the contents of the field you want to modify, then type the new information in the field. The new information overwrites the old information.

4 ♦ When you are done modifying fields, choose OK to save your modifications and close the Update window.

As you update fields, you might find that your modifications are restricted by a variety of factors. For example, you cannot update a calculated field because it is a display only field. Or perhaps your company assigns unique customer numbers so you cannot update the Cust-Num field.
Copying Records

Follow these steps to create a new record based on the contents of an old record. Be sure to follow the guidelines at your site for creating new records based on existing records:

1 ♦ Display the record you want to copy.

2 ♦ Choose the Copy button.

   Results copies the record and displays the copy in the Update window. Results copies all the fields in the record whether or not the fields are displayed.

3 ♦ Since you are creating a new record, you will probably have to update several fields to reflect the new information.

4 ♦ When you are done modifying fields, choose OK to save your new record and close the update window.

Creating Records

Follow these steps to create a new record:

1 ♦ Choose the Add button.

   Results creates a new record that contains all the fields in the table, then displays the record in the Add window. Note that only the fields you chose to display in the query are displayed in the window:

   ![Add - Customer Window]

   Some of the fields might already contain values, as in the Credit-Limit field. These initial values are determined by the business practices established by your company and enforced by the database.

2 ♦ Fill in the empty fields.

3 ♦ When you are done filling in fields, choose OK to save your record and close the Add window.
Deleting Records

Follow these steps to delete a record:

1 ♦ Display the record you want to delete.

2 ♦ Choose the Delete button. A dialog box prompts you to verify that you want to delete the record.

3 ♦ Choose Yes. Results deletes the entire record, including fields that are not displayed in the query.

You might find that you cannot delete a particular record. For example, you might not be able to delete a customer that has outstanding orders. Such restrictions are determined by your company’s business practices and are enforced by your database.

4.3.3 Rearranging Fields

You can change the order in which fields are displayed in the Form view. To move a field, click the field and drag it.

You can lengthen the frame that contains the form by dragging a field to the bottom of the frame. When you drag the field to the bottom of the frame, Results lengthens the frame, moves the buttons to the bottom of the frame, and displays vertical scroll bars.

You can also shorten a frame by moving the fields to the top of the frame.

**NOTE:** Moving a field within a form does not alter either the tab order for the fields or the order in which they are displayed in other views. For more information about changing the tab order of fields, see the “Adding and Removing Display Fields” section in Chapter 7, “Modifying Display Fields.”
4.3.4 Using Frames

A query is contained within a frame. By default, a form uses one frame for each query you create:

If a query includes more than one table, you can tell Results to split the contents of the tables into two frames, allowing you to view the data more easily. For more information, see the “Using Master and Detail Sections to Display Records” section in Chapter 6, “Analyzing Data.”
The following example illustrates a query that uses two frames:

When you split the contents of a query into two frames, Results provides a set of navigation buttons for each frame. The frames will overlap if there is not enough space to display them in the window at the same time. To display both frames simultaneously, modify the frame properties as described below.

You can also enlarge the window by clicking the maximize button or dragging the corner resize handle in the window border.

### 4.3.5 Modifying Frame Properties

You can modify the properties for one or both frames to adjust their position and size.

1. Choose Options → Frame Properties. The Frame Properties dialog box appears:

2. Select the frame you want to modify from the Frames selection list.
3 ♦ Change one or both of the following attributes:

- **Row**—Determines how many rows separate the menu line and the top of the frame. Use this feature to stagger the location of the frames when you want to display several frames simultaneously.

- **Read-Only**—When activated, prevents you from modifying records in the database.

4 ♦ Choose OK.

If you activated Read-Only, the Add, Copy, Update, and Delete buttons are grayed out.

### 4.4 Report View

Use the Report view to create detailed printed reports.

The first figure shows a sample on-screen report format:

An on-screen report lists the **field labels** and **display formats** for the display fields you included in the query. Display formats control the way data appears on-screen and in printed reports. For example, the format for the Name field, (X20), means this field can display up to 20 characters. See the “Changing Display Field Properties” section in Chapter 7, “Modifying Display Fields.”
The next figure uses Print Preview to approximate how the same report looks when printed:

<table>
<thead>
<tr>
<th>Customer Name</th>
<th>Order Num</th>
<th>Extented Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lift Line Skiing</td>
<td>00009</td>
<td>750.40</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00011</td>
<td>551.40</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00019</td>
<td>26.26</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00033</td>
<td>118.05</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00036</td>
<td>102.77</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00041</td>
<td>365.49</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00026</td>
<td>14.72</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00031</td>
<td>1,205.50</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00049</td>
<td>904.80</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00046</td>
<td>16,750.55</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00046</td>
<td>14,212.45</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00034</td>
<td>6.32</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00039</td>
<td>947.70</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00014</td>
<td>898.76</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00029</td>
<td>272.80</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00030</td>
<td>1,945.10</td>
</tr>
<tr>
<td>Lift Line Skiing</td>
<td>00031</td>
<td>846.80</td>
</tr>
</tbody>
</table>

4.4.1 Adding Cover and Final Pages, Headers, and Footers

You can include the following elements in a report:

- **Cover Page**—A separate page at the front of a report.
- **Final Page**—A separate closing page at the end of a report.
- **Headers**—A note at the top of a page. You can use one or all of the following headers: a centered header printed on the first page of the report; a left, centered, or right header printed on each page of the report.
- **Footers**—A note at a bottom of a page. You can use one or all of the following footers: a centered footer printed on the last page of the report; a left, centered, or right footer printed on each page of the report.
Follow these steps to add a cover page, final page, headers, and footers to your document:

1 ♦ Choose Options→Header and Footers. The Headers and Footers dialog box appears:

2 ♦ Choose one of the buttons described here to create a header, footer, or page:

Create a cover page.

Create a special header for the first page.

Create a left-aligned header for all pages.

Create a centered header for all pages.
Create a right-aligned header for all pages.

Create a left-aligned footer for all pages.

Create a centered footer for all pages.

Create a right-aligned footer for all pages.

Create a special footer for the final page.

Create a special final page.

3 ♦ Enter the information that you want to print within the header or footer. To enter the information, do one or both of the following:

- Type text in the Layout box at the top of the window.

  For example, you might want to type **Customer Orders** in a header for a report that lists each customer’s orders. Note that you can enter information that spans several lines by inserting a carriage return at the end of each line.

- Double-click a function in the Function list.

  Functions insert a variable value into the element you create when you print the report. For example, you can use a function to print the current date in every header in your report. Table 4–2 lists the available functions.
The following figure shows an example of a header that centers the words “Customer Orders” and the current date on each page of the report.

Table 4–2: Report Variable Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TODAY</td>
<td>Inserts today’s date.</td>
</tr>
<tr>
<td>TIME</td>
<td>Inserts the time the report started printing.</td>
</tr>
<tr>
<td>NOW</td>
<td>Inserts the current time.</td>
</tr>
<tr>
<td>COUNT</td>
<td>Inserts the number of records from the beginning of the report to the point at which the function is encountered.</td>
</tr>
<tr>
<td>PAGE</td>
<td>Inserts the current page number.</td>
</tr>
<tr>
<td>USER</td>
<td>Inserts the user’s username.</td>
</tr>
<tr>
<td>VALUE</td>
<td>Inserts the current value of any field you select. You cannot use this function for cover, first only, last only, and final pages.</td>
</tr>
</tbody>
</table>

4 ♦ Repeat Steps 2 and 3 to create additional headers, footers, and pages.

5 ♦ Choose OK when you are done creating elements, choose OK.
4.4.2 Selecting Page Sizes

By default, Results prints reports on 8.5x11-inch pages. However, Results provides a variety of paper sizes from which to choose, including legal, tabloid, A3, A4, A5, B5, and 35-mm slide. You can also adjust the report dimensions to print on other paper sizes. For more information, see the “Adjusting Report Dimensions” section.

Follow these steps to choose a different page size:

1 ♦ Choose Options→ Standard Page Size. The Standard Page Size dialog box appears:

![Standard Page Size dialog box]

2 ♦ Select the paper size you want to use, then choose OK.
4.4.3 Adjusting Report Dimensions

Use custom page size to control the position of elements on the printed page. This feature is useful for sizing reports to print on non-standard sized pages. Follow these steps to adjust the report dimensions:

1. Determine the page size that most closely matches the page dimensions you need.
2. Choose Options → Custom Page Size. The Custom Page Size dialog box appears:

Modify the attributes in this dialog box to reformat your report. Table 4–3 describes the Custom Page Size Attributes.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lines Before Header</td>
<td>If you include a header in the report, determines the number of blank lines inserted before the header.</td>
</tr>
<tr>
<td>Left Margin</td>
<td>Determines the left margin, in character spaces.</td>
</tr>
<tr>
<td>Lines Between Header and Body</td>
<td>If you include a header in your report, determines the number of blank lines inserted between the header and the body of the report.</td>
</tr>
</tbody>
</table>
3 ♦ Change the format attributes as desired.

4 ♦ When you are done reformatting the report, choose OK to save your changes.

### 4.4.4 Printing Reports

Follow these steps to print a report:

1 ♦ Choose Query→Print→To Printer. The standard MS-Windows Print dialog box appears.

2 ♦ Select the print settings you want to use, then choose OK.

### 4.5 Label View

Use the Label view to create and print labels. Since many labels, like mailing labels, often use the same fields, Results lets you pick a set of default display fields. The default display fields are selected by your system manager based on your company’s business practices. For example, if you want to create mailing labels, you might tell Results to select the default display fields from the Customer table.
Follow these steps to create labels:

1 ♦ Choose Query→ New→ Label. The Add/Remove Tables dialog box appears.

2 ♦ Select a table from the Available Tables selection list, then choose Add:

   ![Add/Remove Tables dialog box]

   The table appears in the Selected Tables selection list. As you add tables, the Available Tables selection list is updated to display only tables that have a relationship with the table you selected.

3 ♦ Repeat Step 2 to select additional tables.

4 ♦ Choose OK when you are done selecting tables.

   A dialog box prompts you to choose whether you want Results to select the display field for you.

5 ♦ Do one of the following:

   - Choose Yes to select the default display fields.

     Results selects the fields based on the criteria set by your site manager. Thus, some tables might contain numerous display fields and other tables might contain no default display fields. If you want to change the default display fields for a particular table, see your site manager.

   - Choose No to display the Add/Remove Fields dialog box and select the display fields yourself.
The Add/Remove Fields dialog box appears. The dialog box lists the display fields in the order in which they will appear in the labels:

6 ♦ To accept the list of display fields as is, choose OK. To modify the list, insert fields, delete fields, or change the order of the fields as follows:

- To insert a display field, place the cursor where you want to insert the field, then choose Insert Field. The Insert Field dialog box appears. Select a field, then choose OK.
- To delete a display field, select the field then press either CTRL-X or DELETE.
- To delete all the display fields, choose Clear All.
- To change the order of a display field, select the field then press CTRL-X. Position the cursor where you want to insert the field, then press CTRL-V.
- To restore the list of display fields to its original condition, choose Restore Layout.
Results displays the label information:

NOTE: The Field→Aggregates menu selection is not available with the Label view. The Field→Properties menu selection is only available for calculated fields.

The following figure uses Print Preview to show how the labels look when they’re printed:
4.5.1 Selecting Label Types

By default, Results prints labels approximately 3.5 inches wide and 1 inch high in a single-column format. However, Results provides a variety of standard label sizes, including single-column and multi-column formats, Avery labels, large mailing labels, envelope labels, postcard labels, and Rolodex labels.

Follow these steps to choose a label type:

1. Choose Options → Standard Label. The Standard Label dialog box appears:

2. Select the label type you want to use, then choose OK.

4.5.2 Modifying Label Formats

If you find that none of the standard label types is suitable, you can modify the format for one of the existing label types.

Follow these steps to modify the label format:

1. Determine which label type is most suitable. The label type you choose will serve as the basis for your new label.
2 ♦ Choose Options → Custom Label. The Custom Label dialog box appears:

Use the custom label attributes in the dialog box to reformat the label. Table 4–4 describes the custom label attributes.

**Table 4–4: Custom Label Attributes**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left Margin</td>
<td>Determines the left margin, in character spaces.</td>
</tr>
<tr>
<td>Label Width</td>
<td>Determines the label width, in characters.</td>
</tr>
<tr>
<td>Number Across</td>
<td>Determines the number of labels printed horizontally.</td>
</tr>
<tr>
<td>Height</td>
<td>Determines the label height, in lines.</td>
</tr>
<tr>
<td>Omit Blank Lines</td>
<td>Determines whether a line is omitted when the corresponding field within a record is blank.</td>
</tr>
<tr>
<td>Spaces Between</td>
<td>Determines the number of character spaces between labels printed horizontally.</td>
</tr>
<tr>
<td>Copies of Each</td>
<td>Determines the number of times each label is printed. Duplicate labels are printed vertically.</td>
</tr>
<tr>
<td>Lines Between</td>
<td>Determines the number of lines between labels printed vertically.</td>
</tr>
</tbody>
</table>
3 ♦ Change the format attributes as desired.

4 ♦ When you are done reformatting the label, choose OK to save your changes.

**4.5.3 Printing Labels**

Follow these steps to print labels:

1 ♦ Choose Query→ Print→ To Printer. The standard MS-Windows Print dialog box appears.

2 ♦ Select the print settings you want to use, then choose OK.

**4.6 Export View**

Use the Export view to generate ASCII files to use with other software applications. For example, you can use the Export view to create an ASCII file that contains fields from the Customer table, then use the contents of the ASCII file to customize form letters you create from within a word processing application. You can also use the contents of an ASCII file from within a graphics application to create presentations.

The following figures show an export query and the ASCII file it generates:
This export query contains display fields from the Customer table. The format attributes determine how the contents of these fields are formatted for the ASCII file. See the “Modifying Export Types” section for more information about format attributes.

The next figure uses Print Preview to show the ASCII file generated by the Export query. You can use Print Preview to view ASCII export data:

![Print Preview](image)

### 4.6.1 Generating an ASCII File

Once you create the initial export query, you can generate an ASCII file by selecting the export type for the ASCII file, then creating the file. The following sections explain how to do this.

#### Selecting an Export Type

Applications often differ in the way they expect ASCII files to be formatted. Thus, Results provides several export types to format data for a variety of applications:

- **ASCII**
- **ASCII with field-name header**
- **ASCII fixed-width (SDF)**
- **ASCII fixed-width (SDF) with field-name header**
- **Comma-separated value (CSV)**

---

4–27
• DIF with dates as strings
• DIF with dates as numbers
• Microsoft Word (creates an ASCII data merge file)
• Microsoft Word for Windows (creates an ASCII data merge file)
• Progress
• SYLK
• System Data Format
• WordPerfect with crlf (creates an ASCII data merge file)
• WordPerfect without crlf (creates an ASCII data merge file)
• WordStar (creates an ASCII data merge file)

NOTE: If none of the export types is suitable, you can temporarily modify an existing export type by overriding the values of one or more of its format attributes. For more information, see the “Modifying Export Types” section.

By default, Results uses the Progress export type to generate ASCII files.
Follow these steps to choose a different export type:

1 ♦ Determine which export type you want to use.
   
   See the documentation for the application in which you plan to incorporate the data file to determine which export format to use.

2 ♦ Choose Options→ Standard Export. The Standard Export dialog box appears:

![Standard Export dialog box](image1)

3 ♦ Select the export type you want to use, then choose OK.

**Creating an ASCII File**

Follow these steps to create an ASCII file:

1 ♦ Choose Query→ Print→ To File. The Print to File dialog box appears:

![Print to File dialog box](image2)

By default, Results names the file `export.txt` and saves it in your working directory. You can change the defaults, as follows:

- To rename the file, type a new file name in the File field.
- To change the directory in which the file is located, either type the full pathname and filename in the File field, or choose Files and change the directory.
- To append the file to the end of an existing ASCII file, first activate the Append to Existing File toggle box, then in the File field, enter the name of the existing file to which you want to append the file.
4.6.2 Modifying Export Types

If none of the standard export types is suitable, you can temporarily modify an export type by overriding its default settings for one or more format attributes.

Follow these steps to modify an export type:

1 ♦ Determine which export type most closely matches the format you need.

2 ♦ Choose Options→Custom Export and select the attribute you want to modify. Table 4–5 describes these attributes.

Table 4–5: Custom Export Attributes

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Headers</td>
<td>A Yes or No value that indicates whether Results will export the field name as the first line of the export.</td>
</tr>
<tr>
<td>Fixed Width</td>
<td>A Yes or No value that indicates whether the width of the fields is fixed. This value must be set to No unless you select ASCII Fixed-width (SDF) as your export type. The field width determines how Results exports the field data. For example, it defines the width of a character field. For information on formats, see the “Changing Display Field Properties” section in Chapter 7, “Modifying Display Fields.”</td>
</tr>
<tr>
<td>Record Start</td>
<td>The initialization string at the start of a record. The initialization string is the set of characteristics that precedes the record data on each line of the export file. For example, an asterisk (*) might indicate the beginning of a line.</td>
</tr>
<tr>
<td>Record End</td>
<td>The record termination string. The record termination string is the set of characters used to indicate the end of each record value.</td>
</tr>
<tr>
<td>Field Delimiter</td>
<td>The field delimiter string. The field delimiter string is the set of characters used to indicate the beginning and end of each field value.</td>
</tr>
<tr>
<td>Field Separator</td>
<td>The field separator string. The field separator string is the set of characters that separates each field value within a record.</td>
</tr>
</tbody>
</table>
Depending which attribute you select, the following occurs:

- The Output Headers and Fixed Width options toggle between Yes and No. When you set the value to Yes, a check mark appears next to the option name within the menu.
- The Record Start, Record End, Field Delimiter, and Field Separator options display a dialog box that allows you to enter the codes for the string. See the “Modifying Strings” section for more information about modifying these attributes.

**Modifying Strings**

You can enter up to 16 codes for each string. Enter these codes from left to right and top to bottom:

To enter a code, do one of the following:

- Type the code using one of the formats in Table 4–6.

**Table 4–6: Code Formats**

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>’X’</td>
<td>Literal character enclosed in single quotes.</td>
<td>’C’</td>
</tr>
<tr>
<td>^X</td>
<td>Control character preceded by a circumflex.</td>
<td>^Z</td>
</tr>
<tr>
<td>###h</td>
<td>One or two hex digits followed by the letter h.</td>
<td>4Fh</td>
</tr>
<tr>
<td>###o</td>
<td>One, two, or three octal digits followed by the letter o.</td>
<td>374o</td>
</tr>
</tbody>
</table>
Choose the Pick From ASCII Table button and choose a control symbol from the ASCII Codes dialog box.
Changing the Query Selection Criteria

A query’s selection criteria determine which records the query returns from the database and the order in which it returns them. This chapter explains several ways you can change the selection criteria for a query.

This chapter describes:

- Adding and removing tables from the query.
- Changing the relationship between tables in the query.
- Changing the query’s sort order.
- Creating Filters
5.1 Adding and Removing Tables

To add and remove tables from a query:

1 ♦ Choose Tables→ Add/Remove Tables.

Results displays the Add/Remove Tables dialog box:

2 ♦ Add and remove tables as follows:

- To add a table, select the table from the Available Tables selection list and choose the Add button.
- To remove a table, select the table from the Selected Tables selection list and choose the Remove button.

3 ♦ When you are done adding tables to and removing tables from the query, choose OK.

Results displays the Add/Remove Fields dialog box, so you can add or remove display fields. Note that when you remove a table, Results automatically removes the display fields associated with the table.

4 ♦ To add a display field, select the field from the Available Fields selection list and choose the Add button.
5 ♦ In the Selected Fields selection list, the fields are listed in the order they will be displayed in the query view (from left to right). To reorder the display fields, select a field and choose either the Move Up or Move Down button.

Select the fields, then choose Add to include them in the layout. Notice that the field list includes not only database fields, but also includes any calculated fields you defined for the query. Use the Move Up and Move Down buttons to position the order of the fields in the layout:

If you want to include information in a calculated field, but did not create the fields before accessing Label view, choose Field→Add Calculated Field from the menu bar, then create the field. Results inserts the calculated field in the label layout at the cursor position. For information about creating calculated fields, see the “Creating Calculated Fields” section in Chapter 6, “Analyzing Data.”

NOTE: Because the Form view lets you change the position of the fields by dragging the fields in the display, the Move Up and Move Down buttons do not change the position of the fields. They simply change the tab order for the fields.

6 ♦ Choose OK to save your modifications to the query.
5.2 Changing Table Relationships in Multi-table Queries

When you use a multi-table query, Results uses table relationships to determine the set of records it returns. Results contains two types of table relationships, partial and complete. When you create a query, Results automatically establishes a partial relationship between each pair of tables in the query. A partial relationship, also called an inner join, accesses only those records in the first table that have related records in the second table. If you want to access all the records in the first table whether or not they have related records in the second table, change the relationship to a complete relationship. A complete relationship is also called an outer join. See “Record Displays in Multi-table Queries” in Chapter 3, “Query Basics,” for examples of partial and complete relationships.

If you set a complete relationship between a pair of tables and use sort ordering to control the order in which the query retrieves records, Results automatically uses the primary index in the first table in the relationship as the first sort field. (For more information, see the “Sorting Records” section. For example, you might have a query that displays the invoices for your customers by invoice date, as shown in the following example:

```
<table>
<thead>
<tr>
<th>Cust-Num</th>
<th>Invoice-Date</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>88</td>
<td>01/14/90</td>
<td>4,184.00</td>
</tr>
<tr>
<td>91</td>
<td>01/18/90</td>
<td>2,812.98</td>
</tr>
<tr>
<td>69</td>
<td>01/13/90</td>
<td>3,467.67</td>
</tr>
<tr>
<td>72</td>
<td>01/24/90</td>
<td>24,126.79</td>
</tr>
<tr>
<td>82</td>
<td>01/21/90</td>
<td>487.59</td>
</tr>
<tr>
<td>61</td>
<td>01/12/90</td>
<td>4,048.72</td>
</tr>
<tr>
<td>83</td>
<td>01/23/90</td>
<td>11,736.67</td>
</tr>
<tr>
<td>4</td>
<td>01/26/90</td>
<td>660.97</td>
</tr>
<tr>
<td>88</td>
<td>01/23/90</td>
<td>6,655.60</td>
</tr>
<tr>
<td>51</td>
<td>01/27/90</td>
<td>231.25</td>
</tr>
<tr>
<td>59</td>
<td>01/27/90</td>
<td>582.90</td>
</tr>
<tr>
<td>59</td>
<td>02/03/90</td>
<td>5,652.04</td>
</tr>
<tr>
<td>15</td>
<td>02/01/90</td>
<td>1,648.92</td>
</tr>
<tr>
<td>52</td>
<td>02/01/90</td>
<td>645.69</td>
</tr>
<tr>
<td>52</td>
<td>02/03/90</td>
<td>6,655.60</td>
</tr>
<tr>
<td>92</td>
<td>02/04/90</td>
<td>4,998.59</td>
</tr>
</tbody>
</table>
```

Sorted in ascending order by Invoice-Date

If you change the table relationship for this query to a complete relationship, Results will automatically use the Cust-Num field (primary index in the first table) then the Invoice-Date field to sort the query. Thus the query will display the records by invoice date for each customer.
Note that the values for aggregate subtotals and totals only associated with fields from the second table will change to reflect the new sort order when you change the table relationship to a complete relationship. For example, if you created an aggregate total to total the amount of the invoices by date, then changed the relationship between the Customer and Invoice tables to a complete relationship, the aggregate total would then total the amount of the invoices by date for each customer.

Follow these steps to change the relationship between one or more pair of tables:

1 ♦ Choose Table→Relationship Types. The Relationship Types dialog box appears:

![Relationship Types dialog box](image)

Partial relationships are displayed in white and complete relationships are displayed in reverse video.

2 ♦ To change the type of relationship between a pair of tables, simply select the pair of tables you want to modify. Results automatically toggles to the opposite relationship type.

3 ♦ When you are done modifying relationship types, choose OK.
5.3 Sorting Records

By default, Results uses the primary index from the first table you included in the query to
determine the order in which it retrieves and displays records.

The following query displays the items ordered by each customer. Note that Results
automatically uses the primary index, Cust-Num, within the Customer table to sort the records
in ascending order by customer number:

Sorted in ascending order by Cust-Num

You can alter the order in which the query retrieves records by choosing one or more fields as
the criteria for sorting the records.
For example, you might prefer to see the list sorted by order number, starting with the most recent order. In this case, you use the Order-Num field to sort the records in descending order, as shown in the following example:

```
1. Kai Znlu and Billiards 207 00028  384.75
2. Kai Znlu and Billiards 207 00029  450.75
3. Kai Znlu and Billiards 207 00030  187.60
4. Sun Hoop Club 206 00021  810.50
5. Sun Hoop Club 206 00023  810.50
6. Sun Hoop Club 206 00024  1,510.90
7. Sun Hoop Club 206 00025  31.51
8. Sun Hoop Club 206 00026  2,227.90
9. Sun Hoop Club 206 00027  2,206.00
```

Then you might decide that you want to retrieve the orders for each customer, starting with the most recent order. In the Sports database, the order number increases with each new order. Therefore, you use two fields to sort the records: Cust-Num and Order-Num. Cust-Num is sorted in ascending order and Order-Num is sorted in descending order, as shown in the following example:

```
1. Lift Line Skiing 185 00043  896.97
2. Lift Line Skiing 185 00029  35.10
3. Lift Line Skiing 177 00009  947.70
4. Lift Line Skiing 177 00023  872.50
5. Lift Line Skiing 177 00026  1,944.12
6. Lift Line Skiing 177 00024  594.75
7. Lift Line Skiing 177 00031  846.30
8. Lift Line Skiing 79  00031  1,200.00
9. Lift Line Skiing 79  00054  6.82
10. Lift Line Skiing 79  00005  500.00
11. Lift Line Skiing 79  00046  18,710.65
12. Lift Line Skiing 79  00046  14,219.45
13. Lift Line Skiing 36  00003  102.77
14. Lift Line Skiing 36  00041  309.99
15. Lift Line Skiing 36  00009  783.30
```
You can sort on all database fields and on the following types of calculated fields: Math, String Function, Numeric Function, Date Function, and Logical Function. See Chapter 6, “Analyzing Data,” for more information on the different types of calculated functions.

5.3.1 Sort Order and Break Groups

When you use a field to sort records in a query, Results automatically creates a break group based on the field you used to sort the records. A break group is a set of records that have a common value in a certain database field. The last example used the Cust-Num and Order-Num fields to retrieve the orders for each customer, starting with the most recent order. Thus it contains two break groups: one for Cust-Num and one for Order-Num.

Break groups are useful because they allow you to perform calculations on a subset of records in the query. For example, you can count the number of orders for each individual customer or even calculate the total Extended-Price for the items each customer ordered. See the “Creating Aggregate Totals and Subtotals” section in Chapter 6, “Analyzing Data,” for more information about performing calculations on break groups.

5.3.2 Specifying the Sort Order

Follow these steps to change the order in which Results sorts records:

1. Choose Data→Sort Ordering. The Sort Order Fields dialog box appears.

Notice that the Available Fields selection list contains all the fields in the query. You can use any field to sort records, including some calculated fields and fields that are not displayed in the query view. The available calculated fields appear at the top of the Available Fields list:
2 ♦ You can use up to 16 fields to sort the records in the query. To choose the sort fields, select the fields from the Available Fields selection list, then choose Add.

The fields appear in the Selected Fields selection list. Note that the fields appear in the order in which Results uses them to sort the records:

3 ♦ If you selected only one sort field or you are satisfied with the order of the sort fields, go to step 4. Otherwise, to change the order of the sort fields, select one field at a time and choose either the Move Up or Move Down button.

4 ♦ By default, the fields are sorted in ascending order. To sort a field in descending order, select the field, then choose the Descending radio button:

5 ♦ When you are done setting the sort criteria, choose OK to update the sort order and redisplay the query.
5.4 Creating Filters

When you create a query, Results retrieves all the records in the tables you select. However, sometimes you might want to retrieve only a subset of these records. For example, you might want to refine the selection criteria for a query that retrieves customer invoices to retrieve only those invoices for customers in Massachusetts. You might further refine the query to retrieve only those invoices for customers in Massachusetts who have not paid for their merchandise.

To do this, you use a filter to create a set of instructions, called a *WHERE clause*, to instruct the query to retrieve only those records where the State field equals Massachusetts and the Balance field is greater than 0. In this example, the WHERE clause is written as follows:

```
State = "MA" AND Balance > 0
```

In this example, State and Balance are fields; MA is compared to State using the equality operator (=); 0 is compared to Balance using the greater than operator (>); the logical operator AND bonds the two sections of the clause, called expressions, together. See Appendix B, “Comparison Operators,” for a description of the available comparison operators.

Results makes creating a WHERE clause easy. Just select the elements you want to include in the clause and Results generates and formats the clause for you. If, however, you prefer to write and format clauses yourself, Results lets you create WHERE clauses manually.

Results provides you with two similar techniques for generating WHERE clauses:

**Data Selection**

Lets you generate a WHERE clause either manually or by selecting fields and operators and allows Results to format the WHERE clause for you. The WHERE clause can be based on any field from within any table in the query, whether or not the field is a display field. Data Selection also gives you the opportunity to set the selection criteria at run time. Available for all views.

**Query by Example**

Uses a blank form to help you generate a WHERE clause based on one or more display fields. Available only in Form view.

The following sections describe how to use these techniques.
5.4.1 Using Data Selection to Refine a Query

You can use Data Selection to create a WHERE clause automatically or manually. The following sections describe these techniques.

Using Data Selection to Create a WHERE Clause Automatically

Follow these steps to refine a query using Data Selection:

1 ♦ Choose Data → Selection. If there is more than one table available, the Available Tables dialog box appears.

2 ♦ Select the table that contains the fields you want to use to limit the query, then choose OK.

If you are creating a WHERE clause that contains more than one expression and these expressions contain fields from different tables, create the expressions in increments. Select the first table and create the first expression, then select another table to create the second expression, and so on until you complete the clause.

The Data Selection dialog box appears:
3 ♦ If you want Results to prompt you to set your selection criteria at run time, activate the Ask At Runtime toggle box.

By default, Data Selection does not use Ask At Runtime. This means that the values you enter in the WHERE clause are the only values used to select data. To change the selection criteria, you must re-enter Data Selection and create a new WHERE clause. Ask At Runtime lets you modify the values for one or more fields in the WHERE clause each time you run the query. For example, you can tell Results to prompt you for a value to compare to the State field each time you run a query. For more information, see the “Setting Data Selection at Run Time” section.

4 ♦ Double-click the field you want to use to refine the selection criteria.

Results displays the field in the Selection Criteria text box at the bottom of the screen.

5 ♦ Select the comparison operator you want to use to compare a value to the field. See Appendix B, “Comparison Operators,” for a description of these operators.

One of the following occurs:

- If you activated the Ask At Runtime toggle box, the Ask At Run Time Prompt dialog box appears:

  ![Ask At Run Time Prompt](image)

  Type a question that will prompt you to enter a value for the field when you open or run the query. For example, if you are comparing a value to the State field, you might type **Enter a State**. Then choose OK.

- If you did not activate the Ask At Runtime toggle box, the Enter Constant dialog box appears:

  ![Enter Constant](image)
Changing the Query Selection Criteria

Type the value you want to compare to the field, then choose OK. Do not place quotation marks around the value. If quotation marks are required, Results will automatically insert the quotation marks for you when it formats the WHERE clause.

Results formats the WHERE clause and displays it in the Selection Criteria area.

6 ♦ Do one of the following:

- If the WHERE clause is complete, choose OK and redisplay the query based on your selection criteria.
- If you want to add another expression to the WHERE clause based on a field in the current table, determine whether you want to use the AND or the OR logical operator to join the next expression to the expression you just created. Then choose either the AND button or the OR button at the bottom of the dialog box.

The AND operator means both the combined expressions must be true for the record to be selected. If you use State = “MA” AND Balance > 0, Results selects only those records where the customer is from Massachusetts and the customer has a positive balance.

The OR operator means only one of the combined expressions must be true for the record to be selected. If you use State = “MA” OR Cust-Num < 50, Results selects all the records between 1 and 49 plus those records where the customer is from Massachusetts.

- If the expression you want to add to the WHERE clause is based on a field in a different table, choose OK to save the WHERE clause and redisplay the query based on your selection criteria. Then start with Step 1 to create the expression.

When you open the table to create the new expression, the previous expression is not displayed in the Selection Criteria text box. Each table displays its own portion of the WHERE clause only. Results automatically uses the AND operator to join expressions from different tables together and create the WHERE clause for you.

7 ♦ Repeat Steps 3 through 6 to add an expression to the WHERE clause based on a field in the same table.
Using Data Selection to Create a WHERE Clause Manually

Once you are familiar with automatically creating WHERE clauses using Data Selection, you can create and edit WHERE clauses manually.

Follow these steps to create a WHERE clause manually:

1 ♦ Choose Data→Selection.

The Available Tables dialog box appears.

2 ♦ Select the table that contains the fields you want to use to limit the query, then choose OK.

If you are creating a WHERE clause that contains more than one expression and these expressions contain fields from different tables, create the expressions in increments. Select the first table and create the first expression, then select another table to create the second expression, and so on until you complete the clause.

The Data Selection dialog box appears.

3 ♦ Position the pointer in the Selection Criteria text box and click to place the insertion point in the upper-left corner of the editor.

4 ♦ Type the WHERE clause in the Selection Criteria editor. See Appendix B, “Comparison Operators,” for a description of the comparison operators you can use to compare values within the WHERE clause.

Follow these guidelines while creating your WHERE clause:

• Use the complete name for each field in the WHERE clause. A complete field name consists of the database name, the table name, and the field name separated by periods (.). For example, type sports.Customer.City where sports is the name of the database, customer is the name of the table, and city is the name of the field.

• Enclose all text strings in quotation marks (" "). For example, sports.customer.city BEGINS “M”.
Changing the Query Selection Criteria

5 ♦ When you are done entering the WHERE clause, choose the Now button to check the syntax for the clause. An alert box appears.

6 ♦ Choose Cancel. If the syntax is incorrect, fix the error and recheck the syntax.

7 ♦ Choose OK to save the WHERE clause and close the Data Selection dialog box.

Setting Data Selection at Run Time

When you use Data Selection to create a WHERE clause, you can choose the Ask At Runtime option. Choosing Ask At Runtime means that instead of entering a comparison value when you create the WHERE clause, Results prompts you to enter the value when you run the query. This means that you can enter the value when you run the query in an application outside of Results or when you change to the Browse or Form view. When you use the Report, Labels, and Export views, Results does not prompt you to enter a value until you either print the query or use print preview.

To enter a value, type the value in the Ask At Runtime dialog box, then click OK. Note that you do not have to place quotation marks around the value. If the value requires quotation marks, Results automatically inserts them:
To reset the value from within the Form and Browse views, choose Data→ Re-Ask Questions, then type a value in the Ask At Runtime dialog box. To reset the value from within the Report, Labels, and Export view, simply reprint the query or use Print Preview.

**Removing a WHERE Clause Created Using Data Selection**

Follow these steps to remove a WHERE clause that you created using Data Selection:

1 ♦ Choose Data→ Selection.

2 ♦ Select the table that contains the expression you want to remove. The Data Selection dialog box appears:

3 ♦ Select the WHERE clause, then press **DELETE** to remove the clause.

4 ♦ Choose OK to save your changes and close the Data Selection dialog box.

5 ♦ If you created an expression for another table, repeat Steps 1 through 4 for every table that contains an expression.

**5.4.2 Using Query by Example to Refine a Query**

Query by Example is available in the Form view. Use Query by Example when you want to refine the selection criteria for the query by using one or more display fields in the form. If you already created a WHERE clause for the same table using Data Selection, Query by Example automatically deletes the WHERE clause and replaces it with the WHERE clause you create using Query by Example. Follow these steps to use Query by Example:
Changing the Query Selection Criteria

1 ♦ Choose the Query by Example button at the bottom of the form. A blank form appears:

![Query by Example form]

You can use any of these fields to modify the selection criteria for the query.

2 ♦ Go to the first field you want to use and type the selection criteria for the field.

The selection criteria for a field consists of an operator and the value you want the operator to work on. For example, to retrieve all the unpaid invoices, type > 0 in the Balance field.

You can use the following comparison operators: =, <>, <, >, <=, >=, Begins, Matches, and Contains. See Appendix B, “Comparison Operators,” for a description of these operators. If you do not enter a comparison operator in the selection criteria, Query by Example automatically uses the equality operator.

You do not have to place quotation marks (""") around text strings unless the first word in the text string happens to be the name of a comparison operator. For example, to select all the records that pertain to customers in Massachusetts, type “MA” in the State field.

3 ♦ If you want to further refine the selection criteria, enter the selection criteria for one or more additional fields. For example, to display unpaid invoices for the first 49 customers, type <= 49 in the Cust-Num field and > 0 in the Balance field:
4 ♦ When you are finished defining the selection criteria, choose OK. Results saves the selection criteria as a WHERE clause and retrieves the matching records. Note that once you create a WHERE clause, Results maintains the WHERE clause until you change or delete it.

5.4.3 Removing a WHERE Clause Created Using Query by Example

There are two ways to remove a WHERE clause you create through Query by Example. You can choose the Clear Criteria button using Query by Example, or you can use Data Selection to locate the clause, select it, and delete it.

**NOTE:** Although Data Selection displays WHERE clauses you create using Query by Example, Query by Example does not display WHERE clauses you create using Data Selection.

5.5 Using the Data Governor

The Data Governor is an option that limits the number of records a query displays. By default, when you run a query, Results displays all the records in the selected tables that meet the display and data selection criteria. However, the Data Governor allows you to save time and system resources by displaying only a specific number of records. For example, if you have 10,000 orders, you might want to limit the number shown to 30 while you develop and test the query. This allows Results to process 30 orders instead of 10,000 orders when you print or preview the query.

For example, if you run a query that displays the customer name and balance, Results displays all the customers in the selected tables. You can use the Data Governor to display only the first 20 records.

You can only use the Data Governor in the Report, Label, and Export views.

Follow these steps to use the Data Governor:

1 ♦ Choose Data→Governor. The Data Governor dialog box appears:
2 ♦ Enter the number of records you want to display.

3 ♦ Activate the Include in Generated Code toggle box if you want to include this limit in the generated code.

This means that when you run the query from an application, Results displays only the number of records specified in the Number of Records field. If you do not activate this toggle box, Results displays all the records when you run the query from an application.

4 ♦ Choose OK.
Analyzing Data

Results provides a variety of techniques for analyzing the data in your queries. This chapter describes how to use the following techniques:

- Splitting the query view into master and detail sections to reduce the display of repetitive information.
- Creating calculated fields to calculate values based on constants and the values of other fields in the query.
- Creating aggregate totals and subtotals for one or more columns of fields within a report.
- Displaying data in break groups as totals only.
6.1 Using Master and Detail Sections to Display Records

When you create a query that contains more than one table, Results automatically displays all the fields from the tables in one section. To help you analyze data, you can separate the information contained in these tables into two sections, called Master and Detail.

For example, if your query uses fields from the Customer, Order, and Order-Line tables to list the items each customer ordered, Results places the records in one section by default, as in the following example:

In this example, the query retrieves a record for each item number within each order. Many of the records contain identical information. To reduce the amount of repetitive information displayed in the view, you can split the view into two sections, Master and Detail. A Master section begins a new order and its corresponding Detail section contains the specific items ordered. You can use the Master-Detail option with the Browse, Report, and Form query views.
Splitting composite records into Master and Detail sections does not alter the way in which the query retrieves the records. It simply alters the way in which Results displays the records within the query view:

In this example, the Master section contains fields from the Customer and Order tables and the Detail section contains fields from the Order-Line table.
Follow these steps to split composite records into Master and Detail sections:

1 ♦ Choose Options→Master-Detail. The Master-Detail dialog box appears:

![Master-Detail dialog box]

2 ♦ Determine how you want to split the tables, then select a break point and choose OK.

When you split composite records into Master and Detail sections the Form or Browse views, Results automatically places each section in its own frame. See the “Browse View” and “Form View” sections in Chapter 4, “Using Query Views,” for more information about frames.

6.1.1 Displaying Composite Records in One Section

Follow these steps to remove the Master and Detail sections and display composite records in one section:

1 ♦ Choose Options→Master-Detail.

2 ♦ Select <<One Section>>, then choose OK.
6.2 Calculated Fields

So far you have displayed fields that already exist in the database. However, you can create your own column of data, called calculated fields, to help you analyze the information in your query.

For example, you can create a field called Total Price that automatically multiplies the price of each item a customer orders by the number of items ordered, as shown in the following figure:

Total Price multiplies the value of the Price and Qty fields for each record in the database.
Calculated fields are display fields only, so neither the field nor its contents are saved to the database. Table 6–1 shows the types of calculated fields you can create.

### Table 6–1: Calculated Fields

<table>
<thead>
<tr>
<th>Calculated Field Types</th>
<th>Description</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>Percent of Total</td>
<td>Expresses the percent of total that the value of a field represents within the query. For example, you can display the percent of total for each sales representative’s monthly sales figures.</td>
<td>Available in the Report and Export views only.</td>
</tr>
<tr>
<td>Running Total</td>
<td>Displays the running total of any numeric field or expression. A running total increments for each line of the query. That is, the value displayed in that column on any line in the query is the sum of the field value for that and all previous lines in the query. For example, if the value in the first record is 1 and the value in the second record is 3, the running total for the first line is 1 and the running total for the second record is 4 (1 plus 3).</td>
<td>Available in the Report and Export views only.</td>
</tr>
<tr>
<td>Counter</td>
<td>Displays a running counter. Use counters for line numbering and counting records.</td>
<td>Available in the Report and Export views only.</td>
</tr>
<tr>
<td>Stacked Array</td>
<td>Displays the elements in an array in a vertical column.</td>
<td>Available in the Report view only.</td>
</tr>
<tr>
<td>Lookup</td>
<td>Displays the value of a field from a table not included in the query.</td>
<td>Available in all the query views except Labels.</td>
</tr>
<tr>
<td>Math</td>
<td>Defines a math expression based on the value of one or more fields. Use the following operations to calculate the value of the two fields: add, subtract, multiply, divide, or raise to a power. For example, you can create a field named Total Price to multiply the value of the Price and Qty fields for each record in the query.</td>
<td>Available in all views.</td>
</tr>
<tr>
<td>String Function</td>
<td>Defines a display field based on a string expression.</td>
<td>Available in all views.</td>
</tr>
</tbody>
</table>
6.2.1 Creating Calculated Fields

You can create calculated fields from within any query view except the Labels view. See Table 6–1 for a list of the views in which individual calculated fields are available.

Follow these steps to create a calculated field:

1 ♦ Choose Field→Add Calculated Field, then select the field you want to create.

   Results displays the Add field dialog box for the type of calculated field you selected. The following sections describe these dialog boxes.

2 ♦ Use the Add Field dialog box to specify the parameters for the field, then choose OK. The Properties dialog box appears.

   For example, you can choose the Assistant button to modify how the data in the field is displayed. You can also change the name of a calculated field by selecting the Rename button. See the “Renaming Calculated Fields” section later in this chapter.

3 ♦ Set the properties for the field you created. See the “Changing Display Field Properties” section in Chapter 7, “Modifying Display Fields.”

---

Table 6–1: Calculated Fields

<table>
<thead>
<tr>
<th>Calculated Field Types</th>
<th>Description</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>Numeric Function</td>
<td>Defines a display field based on a numeric expression.</td>
<td>Available in all views.</td>
</tr>
<tr>
<td>Date Function</td>
<td>Defines a display field based on a date calculation.</td>
<td>Available in all views.</td>
</tr>
<tr>
<td>Logical Function</td>
<td>Defines a logical display field based on the value of one or more fields in the query.</td>
<td>Available in all views.</td>
</tr>
</tbody>
</table>
Adding a Percent of Total Field

The Add Field - Percent of Total dialog box lets you specify the field for which you want to
calculate the percent of total. To specify a field, select the field and choose OK:

The following example uses Percent of Total to calculate each sales representative’s percent of
total for the month of January:

<table>
<thead>
<tr>
<th>Name</th>
<th>Region</th>
<th>Percent of Total (January)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Breen, Rubia B.</td>
<td>East</td>
<td>6.7%</td>
</tr>
<tr>
<td>Final, Nick X.</td>
<td>Central</td>
<td>7.6%</td>
</tr>
<tr>
<td>Donna Sentail</td>
<td>Southern</td>
<td>16.9%</td>
</tr>
<tr>
<td>Gillee Khner</td>
<td>Bretagne</td>
<td>6.7%</td>
</tr>
<tr>
<td>Harry Munig</td>
<td>Eretige</td>
<td>16.9%</td>
</tr>
<tr>
<td>Jan Loopostel</td>
<td>Nerd</td>
<td>9.2%</td>
</tr>
<tr>
<td>Karl Eo-Kengpoin</td>
<td>Finland</td>
<td>9.4%</td>
</tr>
<tr>
<td>Robert Holler</td>
<td>Austria</td>
<td>17.6%</td>
</tr>
<tr>
<td>Smith, Spike Louis</td>
<td>West</td>
<td>12.6%</td>
</tr>
</tbody>
</table>
Adding a Running Total Field

The Add Field - Running Total dialog box lets you select the field for which you want to calculate a running total. To specify a field, select the field and choose OK:

The following example lists the running total for the Total-Paid field:
Adding a Counter

The Add Field - Counter dialog box lets you specify the parameters for the counter field:

![Add Field - Counter dialog box]

To create the Counter field, set the following parameters:

- **Starting Number**—Specifies the number from which to begin counting.
- **Number to Add**—Specifies the increment between the numbers.
- **Sections Used In**—Select the sections you want to count: Master, Detail, or both. For more information about master and detail sections, see the “Using Master and Detail Sections to Display Records” section in this chapter.
The following example uses the Counter field to count the total number of orders in the Master section:

Adding a Stacked Array Field

When a field consists of several elements, each of which contains its own value, the field is called an array. By default, the values in the array are listed horizontally. To list them in a vertical column, use the Stacked Array calculated field.

The Add Field - Stacked Array dialog box lets you specify the array you want to stack vertically. To specify the array, select the array and choose OK:
In the following example, the Stacked Array field displays the contents for Month-Quota in a vertical column:

![Image](image1.png)

**Adding a Lookup Field**

The Add Field - Lookup Source dialog box allows you to display the value of a field in a table not currently in the query.

To use this option, both the table that contains the field you want to display and one of the tables in your query must contain a field that stores the same kind of information. This similarity between the two fields lets you establish a relationship between the two tables. For example, you might use a field in the Customer table called Cust-Num and a field in the Invoice table called ID-Num to identify your customers. In this case, they both store a set of numbers that identify your customers:

![Image](image2.png)
For more information about table relationships, see the “Record Displays in Multi-table Queries” section in Chapter 3, “Query Basics,” and the “Changing Table Relationships in Multi-table Queries” section in Chapter 5, “Changing the Query Selection Criteria.”

Follow these steps to look up a field in a table not included in the query:

1 ♦ Select a field from one of the tables in your query that contains the same type of information as a field in the table with which you are establishing a relationship.

2 ♦ Choose OK. The Add Field - Lookup Matching Field dialog box appears:

3 ♦ Select the table that contains the field you want to look up.

4 ♦ Select a field that contains the same type of information as the field you selected in Step 1. This establishes a relationship between the two tables.
5 ♦ Choose OK. The Add Field - Lookup Display Field dialog box appears:

![Add Field - Lookup Display Field dialog box](image)

6 ♦ Select the field that contains the information you want to display.

7 ♦ Type a value to display in place of the lookup field when Results cannot find a matching field value in one or more records. By default, Results displays a question mark (?) when it cannot find a value.

8 ♦ Choose OK.

The following example displays a lookup field called Region from a table called State that is not included in the query:

![Example output](image)
Adding a Math Expression

The Add Field - Math dialog box allows you to create a math expression based on the value of two fields. When you select the Math option, Results displays the Add Field - Math dialog box:

Follow these steps to create a math expression:

1. Select the mathematical type of function to perform. Results lists the available display fields in the Function/Field selection list and displays an empty expression based on the function you choose:
Double-click one of the following to create the first part of the expression:

- **A field**—Uses the value of the field in the first part of the expression.
- **Constant Value**—Lets you enter a value to use in the first part of the expression. For example, you can use constant value field to insert a number to calculate within the expression.
- **Subexpression**—Lets you enter a subexpression as the first value in the expression. A subexpression is an expression within another expression.

Results creates the first part of the expression and displays it in the Expression field at the bottom of the dialog box.

If the expression contains a second value, double-click a field, constant value, or subexpression to create the last part of the expression.

Results creates the remaining part of the expression and displays the entire expression in the Expression selection list:
4 ♦ Choose OK to save the expression.

The following example contains a calculated field named Total Price that multiplies the value of the Price and Qty fields for each record in the query:
Adding a String Function

The Add Field - String Function dialog box allows you to create a string expression:

Follow these steps to create a string expression:

1. In the Function/Field selection list, double-click the function you want to perform. Table 6–2 describes these functions.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Combine Strings</td>
<td>Combines two or more strings into one string.</td>
</tr>
<tr>
<td>Current Time</td>
<td>Returns the current time.</td>
</tr>
<tr>
<td>Display as Time</td>
<td>Displays a string in time format.</td>
</tr>
<tr>
<td>Greater of Two Strings</td>
<td>Returns the greater (larger) of two strings.</td>
</tr>
<tr>
<td>If first expression is true return second else third string</td>
<td>Defines an expression that makes a decision based on string values. If the first string expression is true, the second expression is returned. If the first string expression is false, the third expression is returned.</td>
</tr>
<tr>
<td>Length of String</td>
<td>Returns the number of characters in a string. For example, the length of the string “Progress” is 8.</td>
</tr>
</tbody>
</table>

Table 6–2: String Functions (1 of 2)
Results does the following:

- Lists the available display fields in the Function/Field selection list.
- Displays an empty expression based on the function you chose in Step 1.

2 • Double-click one of the following to create the first part of the expression:

- **A field**—Uses the value of the field in the first part of the expression.
- **Constant Value**—Lets you enter a value to use in the first part of the expression. For example, you could use constant value to insert a comma or a space within a string.
- **Sub-expression**—Lets you enter a subexpression as the first value in the expression. A subexpression is simply an expression within another expression.

Results creates the first part of the expression and displays it in the Expression field at the bottom of the dialog box.

---

**Table 6-2: String Functions**

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lesser of Two Strings</td>
<td>Returns the lesser (smaller) of two strings.</td>
</tr>
<tr>
<td>Name of Month</td>
<td>Returns the current month.</td>
</tr>
<tr>
<td>Name of Weekday</td>
<td>Returns the current day.</td>
</tr>
<tr>
<td>String Constant or Field</td>
<td>Lets you build an expression with either a string constant or the value of a character field.</td>
</tr>
<tr>
<td>Substring</td>
<td>Returns a substring. A substring is part of a string. For example, “hold” is a substring of “credit hold.”</td>
</tr>
<tr>
<td>User ID</td>
<td>Returns the user ID.</td>
</tr>
</tbody>
</table>

(2 of 2)
3 ♦ If your expression contains a second value, double-click a field, constant value, or subexpression to create the last part of the expression.

Results creates the remaining part of the expression and displays the entire expression in the Expression field:

4 ♦ Choose OK to save the expression.

The following example contains a calculated field named City/State that uses the Combine String function to combine the values of the City and State fields into one field:
Note that the City/State field uses a constant value that contains a comma and space to separate the city and state. This constant value is added to the expression through a subexpression. The following figure illustrates the expression used in this example:

\[
\text{string (city)} + \text{string(constant value)} + \text{string(state)}
\]

Subexpression

**Adding a Numeric Function**

Use the Numeric function to create a numeric expression. When you select the Numeric Function option, Results displays the Add Field - Numeric Function dialog box:
Follow these steps to create a numeric expression:

1. In the Function/Field selection list, double-click the function you want to perform. Table 6–3 describes these functions.

**Table 6–3: Numeric Functions**

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absolute Value</td>
<td>Returns the absolute value of a number. The absolute value is the positive value of a given number. For example, the absolute value of -3 is 3; the absolute value of 5 is 5.</td>
</tr>
<tr>
<td>Cube Root</td>
<td>Returns the cube root of a number. The cube root of a number is a number that when multiplied by itself three times, equals the number. For example, the cube root of 8 is $2 \times 2 \times 2$.</td>
</tr>
<tr>
<td>Greater of Two Numbers</td>
<td>Returns the largest number from a list of numbers. For example, if a list consists of two numbers, 24 and 55, the function returns 55.</td>
</tr>
<tr>
<td>If first expression is true return second else third number</td>
<td>Defines an expression that makes a decision. If the first expression is true, the second expression is returned. If the first expression is false, the third expression is returned. For example, you can define an expression that calculates a discount based on the credit limit of a customer.</td>
</tr>
<tr>
<td>Log Base e</td>
<td>Returns the logarithm based on the value e. The value of e is 2.7182818.</td>
</tr>
<tr>
<td>Log Base n</td>
<td>Returns the natural logarithm for a number for a given base. For example, $2^5$ is 32. The natural logarithm for 32 with base 2 is 5.</td>
</tr>
<tr>
<td>Numeric Constant or Field</td>
<td>Defines a field’s value</td>
</tr>
<tr>
<td>Remainder</td>
<td>Returns the remainder of a division operation.</td>
</tr>
<tr>
<td>Round</td>
<td>Rounds a value to the nearest whole number. For example, rounding 5.2 returns 5 and rounding 5.7 returns 6.</td>
</tr>
</tbody>
</table>
Results does the following:

- Lists the available display fields in the Function/Field selection list.
- Displays an empty expression based on the function you chose in Step 1 within the Expression scroll box.

2 ♦ Double-click one of the following to create the first part of the expression:

- **A field**—Uses the value of the field in the first part of the expression.
- **Constant Value**—Lets you enter a value to use in the first part of the expression. For example, you can enter a number to calculate within the expression.
- **Subexpression**—Lets you enter a subexpression as the first value in the expression. A subexpression is simply an expression within an expression.

Results creates the first part of the expression and displays it in the Expression field at the bottom of the dialog box.

### Table 6–3: Numeric Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smaller of Two Numbers</td>
<td>Returns the smaller of two numbers. For example, if the function compares the numbers 18 and 29, it returns the number 18.</td>
</tr>
<tr>
<td>Square Root</td>
<td>Returns the square root of a number. For example, the square root of 9 is 3.</td>
</tr>
<tr>
<td>Truncate</td>
<td>Truncates a number.</td>
</tr>
</tbody>
</table>
3 ♦ If the expression contains a second value, double-click a field, constant value, or subexpression to create the last part of the expression.

Results creates the remaining part of the expression and displays the entire expression in the Expression field:

4 ♦ Choose OK to save your expression.

The following example contains a calculated field named Round Amount that rounds the amount of each customer’s invoice to the nearest whole dollar:
Adding a Date Function

The Add Field - Date Function dialog box allows you to define a date calculation:

Follow these steps to add a date function:

1. In the Function/Field selection list, double-click the function you want to perform. Table 6–4 describes these functions.

### Table 6–4: Date Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Days to Date Value</td>
<td>Adds the number of days you specify to a date and returns the value.</td>
</tr>
<tr>
<td>Current Date</td>
<td>Returns the current date.</td>
</tr>
<tr>
<td>Day of Month</td>
<td>Returns the day of the month for the date you specify.</td>
</tr>
<tr>
<td>Day of Week</td>
<td>Returns the day of the week for the date you specify in numeric format, where the value “1” begins with Sunday.</td>
</tr>
<tr>
<td>Difference between Two Dates</td>
<td>Returns the difference between two dates.</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Earlier of Two Dates</td>
<td>Returns the earlier of two dates. For example, if the function compares the dates 01/05/95 and 01/09/99, it returns 01/05/95.</td>
</tr>
<tr>
<td>If first expression is true return second else third date</td>
<td>Defines an expression that makes a decision. If the first part of the expression is true, the function returns the second date; if the first part of the expression is not true, the function returns the third date.</td>
</tr>
<tr>
<td>Later of Two Dates</td>
<td>Returns the later of two dates. For example, if the function compares the dates 01/05/95 and 01/09/99, it returns 01/09/99.</td>
</tr>
<tr>
<td>Month of Year</td>
<td>Returns the number of the month for the date you specify.</td>
</tr>
<tr>
<td>Subtract Days from Date Value</td>
<td>Subtracts the number of days you specify from a date and returns the value.</td>
</tr>
<tr>
<td>Year Value</td>
<td>Returns the year for the date you specify. For example, the date 04/05/99 is returned as 1999.</td>
</tr>
</tbody>
</table>
Results does the following:

- Lists the available display fields in the Function/Field selection list.
- Displays an empty expression based on the function you chose in Step 1 within the Expression editor box:

2. Double-click one of the following to create the first part of the expression:

- **A field**—Uses the value of the field in the first part of the expression.
- **Constant Value**—Lets you enter a date to use in the first part of the expression.
- **Current Date**—Uses the current date each time you run the query.
- **Subexpression**—Lets you enter subexpression as the first value in the expression.

Results creates the first part of the expression and displays it in the Expression field at the bottom of the dialog box.
3 ♦ Double-click a field, constant value, current date, or subexpression to create the last part of the expression.

Results creates the remaining part of the expression and displays the entire expression in the Expression field:
4 ♦ Choose OK to save your expression.

The following example contains a calculated field named Delivery Time that uses the Differences Between Two Dates function to calculate the difference between the Ordered and Shipped dates. Note that a question mark displays in the Delivery Time field for those records that Results cannot calculate because the order has not shipped:

**Adding a Logical Function**

The Add Field - Logical Function dialog box allows you to create a logical expression:
Follow these steps to create a logical expression:

1 ♦ In the Function/Field selection list, double-click the function you want to perform. Table 6–5 describes these functions.

**NOTE:** Many of the functions in Table 6–5 contain comparison operators. See Appendix B, “Comparison Operators.”

### Table 6–5: Logical Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Begins</td>
<td>Returns the logical value “yes” for strings that begin with the letter you specify or the logical value “no” for strings that do not begin with the letter you specify.</td>
</tr>
<tr>
<td>Dates Equal</td>
<td>Returns the logical value “yes” for dates equal to the value you specify or the logical value “no” for dates not equal to the value you specify.</td>
</tr>
<tr>
<td>Dates Greater or Equal</td>
<td>Returns the logical value “yes” for dates larger or equal to the value you specify or the logical value “no” for dates smaller than the value you specify.</td>
</tr>
<tr>
<td>Dates Greater Than</td>
<td>Returns the logical value “yes” for dates larger than the value you specify or the logical value “no” for dates smaller or equal to the value you specify.</td>
</tr>
<tr>
<td>Dates Less or Equal</td>
<td>Returns the logical value “yes” for dates smaller or equal to the value you specify or the logical value “no” for dates larger than the value you specify.</td>
</tr>
<tr>
<td>Dates Less Than</td>
<td>Returns the logical value “yes” for dates smaller than the value you specify or the logical value “no” for dates larger or equal to the value you specify.</td>
</tr>
<tr>
<td>Dates Not Equal</td>
<td>Returns the logical value “yes” for dates not equal to the value you specify or the logical value “no” for dates equal to the value you specify.</td>
</tr>
<tr>
<td>Logical AND</td>
<td>Lets you join two logical expressions together. The function returns the value “yes” when both expressions are true and the value “no” when either one or both expressions are false.</td>
</tr>
</tbody>
</table>
### Table 6-5: Logical Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logical OR</td>
<td>Lets you join two logical expressions together. The function returns the value “yes” when either expression is true and the value “no” when neither expression is true.</td>
</tr>
<tr>
<td>Matches</td>
<td>Returns the logical value “yes” for strings that match the characters you specify or the value “no” for strings that do not match the characters you specify.</td>
</tr>
<tr>
<td>Negate logical expression (NOT)</td>
<td>Returns the logical value “no” for logical expressions that are true and the logical value “yes” for logical expressions that are false.</td>
</tr>
<tr>
<td>Numbers Equal</td>
<td>Returns the logical value “yes” for numbers equal to the value you specify or the logical value “no” for numbers not equal to the value you specify.</td>
</tr>
<tr>
<td>Numbers Greater or Equal</td>
<td>Returns the logical value “yes” for numbers larger or equal to the value you specify or the logical value “no” for numbers smaller than the value you specify.</td>
</tr>
<tr>
<td>Numbers Greater Than</td>
<td>Returns the logical value “yes” for numbers larger than the value you specify or the logical value “no” for numbers smaller or equal to the value you specify.</td>
</tr>
<tr>
<td>Numbers Less or Equal</td>
<td>Returns the logical value “yes” for numbers smaller or equal to the value you specify or the logical value “no” for numbers larger than the value you specify.</td>
</tr>
<tr>
<td>Numbers Less Than</td>
<td>Returns the logical value “yes” for numbers smaller than the value you specify or the logical value “no” for numbers larger or equal to the value you specify.</td>
</tr>
<tr>
<td>Numbers Not Equal</td>
<td>Returns the logical value “yes” for numbers not equal to the value you specify or the logical value “no” for numbers equal to the value you specify.</td>
</tr>
<tr>
<td>Strings Equal</td>
<td>Returns the logical value “yes” for strings equal to the value you specify or the logical value “no” for strings not equal to the value you specify.</td>
</tr>
<tr>
<td>Strings Greater or Equal</td>
<td>Returns the logical value “yes” for strings larger or equal to the value you specify or the logical value “no” for strings smaller than the value you specify.</td>
</tr>
</tbody>
</table>
Table 6–5: Logical Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Strings Greater Than</td>
<td>Returns the logical value “yes” for strings larger than the value you specify or the logical value “no” for strings smaller or equal to the value you specify.</td>
</tr>
<tr>
<td>Strings Less or Equal</td>
<td>Returns the logical value “yes” for strings smaller or equal to the value you specify or the logical value “no” for strings larger than the value you specify.</td>
</tr>
<tr>
<td>Strings Less Than</td>
<td>Returns the logical value “yes” for strings smaller than the value you specify or the logical value “no” for strings larger or equal to the value you specify.</td>
</tr>
<tr>
<td>Strings Not Equal</td>
<td>Returns the logical value “yes” for strings not equal to the value you specify or the logical value “no” for strings equal to the value you specify.</td>
</tr>
</tbody>
</table>

2 ♦ Double-click one of the following to create the first part of the expression:

- **A field**—Uses the value of the field in the first part of the expression.
- **Constant Value**—Lets you enter a date to use in the first part of the expression.
- **Current Date**—Uses the current date each time you run the query.
- **Subexpression**—Lets you enter subexpression as the first value in the expression. A subexpression is an expression within an expression.

Results creates the first part of the expression and displays it in the Expression field at the bottom of the dialog box.
3 ♦ If your expression contains a second value, double-click a field, constant value, current date, or subexpression to create the last part of the expression.

Results creates the remaining part of the expression and displays the entire expression in the Expression field:

4 ♦ Choose OK to save your expression.
By default, Results uses the display values “yes” and “no” to represent true and false. To substitute a different set of display values for true and false, choose the Assistant button in the Properties dialog box and modify the display values. See the “Changing Display Field Properties” section in Chapter 7, “Modifying Display Fields.”

The following example contains a calculated field named On Time that uses the Dates Less or Equal function to determine whether the date an order is shipped is equal to or less than the promise date for the order:

![Example Table]

6.2.2 Renaming Calculated Fields

When you create a calculated field, Results automatically names the field with “qbf-” followed by a unique number. For example, Results might name a field “qbf-004.” While qbf-004 might be a logical name to Results, it is not intuitive. Therefore, you can rename a calculated field with a more descriptive name. For example, if qbf-004 calculates the number of days between the current date and the ship date, rename it Days_To_Ship.
Follow these steps to rename a calculated field:

1 ♦ Choose Field→Properties. The Properties dialog box appears:

![Properties dialog box]

2 ♦ Select the calculated field whose name you want to change from the Name drop-down list.

3 ♦ Choose the Rename button. The Rename Field dialog box appears:

![Rename Field dialog box]

4 ♦ Enter the new calculated field name, then choose OK to rename the field and return to the Properties dialog box.

The field name can be up to 32 characters long and consist of alphabetic characters (A-Z or a-z), digits (0-9), and special characters ($, &, #, -, and _). In addition, field names must begin with a letter (a-Z or a-z). The field name must also be unique within the query and cannot contain spaces.

5 ♦ Choose OK.
6.2.3 Removing Calculated Fields

Use the same procedure to remove a calculated field that you use to remove a display field. The following steps briefly outline how to remove a calculated field. For more information, see the “Adding and Removing Display Fields” section in Chapter 7, “Modifying Display Fields.”

1 ♦ Choose Field→Add/Remove Fields. The Add/Remove Fields dialog box appears.

2 ♦ Select the calculated field you want to remove from the Selected Fields selection list, then choose Remove.

3 ♦ Choose OK to save your changes.

6.3 Aggregate Fields

An aggregate field calculates the value of a column of data. For example, you can use an aggregate value to count the total number of customer orders in a report. Results provides the following aggregate values:

- **Total**—The combined value for the column of data.
- **Count**—The number of rows of data in the column.
- **Minimum**—The smallest value in the column of data.
- **Maximum**—The largest value in the column of data.
- **Average**—The average value of all the data in the column.

Use aggregate values to calculate the value of all the data in the column or to calculate the value of one or more groups of data within the column, called break groups. When you calculate the values of all the data in a column, you create an aggregate called a total; when you calculate the value of a break group, you create a subtotal. The following sections describe totals and subtotals.
### 6.3.1 Totals

When you create a total for a particular field, Results calculates the value for the entire column and places it in the summary area beneath the column at the bottom of the last page of the report. The following example shows a report that calculates the number of customer orders and the average price of the items ordered:

Counts the number of customer orders and places the result in the summary section of the report.  
Calculates the average price of all the items ordered and places the result in the summary section of the report.
6.3.2 Subtotals

If you use a sort order to create break groups within the report, you can calculate the subtotal for each break group. For information about sorting with break groups, see the “Sorting Records” section in Chapter 5, “Changing the Query Selection Criteria.”

For example, a report that is sorted in ascending order by Cust-Num and descending order by Order-Num, contains two break groups: one for customers and one for orders. You can use either the break group associated with Cust-Num or the break group associated with Order-Num to create subtotals.

The following report contains a subtotal associated with the Order-Num break group to calculate the total price for all the items in each order:
The following report contains an additional subtotal based on the Cust-Num break group to calculate the total price of all the items each customer ordered. This subtotal includes all the items in all the orders for each customer:

As shown in this example, you can use any combination of subtotals for each break group. You can create an aggregate field based on any database field and on the following types of calculated fields: Math, String Function, Numeric function, Date Function, and Logical Function.
### 6.3.3 Creating Aggregate Totals and Subtotals

Follow these steps to create one or more aggregate totals and subtotals:

1. Choose Field→Aggregates. The Field Aggregates dialog box appears:

![Field Aggregates dialog box](image)

2. Create a total or subtotal as follows:

   - To create a total, select the field for which you want to calculate the total, select summary line from the Break-By Fields selection list, and select the aggregate value you want to create.

     For example, to count all the orders in the report, select Order-Num from the Query Fields selection list, select summary line from the Break-By Fields selection list, then select Count.

   - To create a subtotal, select the field for which you want to calculate the subtotal, select the sort field you want to use from the Break-By Fields selection list, and select the aggregate value you want to create.

     For example, to calculate the total price of the items each customer ordered, select the Price field from the Query Fields selection list, select the Cust-Num field from the Break-By Fields selection list, then select Total.

3. Repeat Step 2 to create additional aggregates.

4. When you are finished creating aggregates, choose OK.
6.4 Using a Totals-Only Summary

In the Report and Export Views, Totals-Only Summary provides a quick way to calculate and display the combined value of a column of data for a specific break group. For more information, see the “Sorting Records” section in Chapter 5, “Changing the Query Selection Criteria.”

The following example shows a query that does not use Totals Only Summary. In this example, the query displays the orders for each customer. The query uses the Cust-Num field to sort the orders for each customer in ascending order. Thus, it contains one break group—a break group for customers:

<table>
<thead>
<tr>
<th>Cust-Num</th>
<th>Order-num</th>
<th>Item-num</th>
<th>Extended-Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>00089</td>
<td></td>
<td>769.90</td>
</tr>
<tr>
<td>6</td>
<td>00089</td>
<td></td>
<td>140.40</td>
</tr>
<tr>
<td>6</td>
<td>00011</td>
<td></td>
<td>751.90</td>
</tr>
<tr>
<td>6</td>
<td>00019</td>
<td></td>
<td>38.70</td>
</tr>
<tr>
<td>6</td>
<td>00063</td>
<td></td>
<td>118.05</td>
</tr>
<tr>
<td>6</td>
<td>00093</td>
<td></td>
<td>106.77</td>
</tr>
<tr>
<td>86</td>
<td>00041</td>
<td></td>
<td>384.48</td>
</tr>
<tr>
<td>79</td>
<td>00066</td>
<td></td>
<td>16.22</td>
</tr>
<tr>
<td>79</td>
<td>00031</td>
<td></td>
<td>1,208.30</td>
</tr>
<tr>
<td>79</td>
<td>00064</td>
<td></td>
<td>4.22</td>
</tr>
<tr>
<td>79</td>
<td>00039</td>
<td></td>
<td>508.90</td>
</tr>
<tr>
<td>79</td>
<td>00046</td>
<td></td>
<td>1,970.85</td>
</tr>
<tr>
<td>79</td>
<td>00045</td>
<td></td>
<td>14,317.45</td>
</tr>
<tr>
<td>177</td>
<td>00089</td>
<td></td>
<td>947.70</td>
</tr>
<tr>
<td>177</td>
<td>00029</td>
<td></td>
<td>270.83</td>
</tr>
<tr>
<td>177</td>
<td>00030</td>
<td></td>
<td>1,946.13</td>
</tr>
</tbody>
</table>
Since the query contains a break group based on the Cust-Num field, you can use Totals Only Summary to calculate and display the combined value of the Extended-Price field for each set of customer orders.

When you use Totals Only Summary, Results summarizes the information and displays one record for each group containing the total for the group. Note that when you use Totals Only Summary the Export view, Results displays the preceding records in the group in addition to the record containing the total.

Follow these steps to use Totals Only Summary.

1. Verify that you have at least one break group. If you have more than one break group, Total Only Summary automatically uses the break group based on the last field in your sort list to perform the total.
2 ♦ Choose Options→Totals Only Summary. The Totals Only Summary dialog box appears.

3 ♦ Select one or more fields to total, then choose OK.
This chapter describes the following techniques for modifying display fields:

- Adding and removing display fields from the query view
- Changing display field properties
7.1 Adding and Removing Display Fields

The Add/Remove Fields option lets you change the fields displayed in the query view.

Follow these steps to add and remove display fields from the query view:

1 ♦ Choose Fields→Add/Remove Fields. Results displays the Add/Remove Fields dialog box:

   ![Add/Remove Fields dialog box]

2 ♦ Add and remove fields as follows:
   
   • To add a field to the query layout, select the field from the Available Fields selection list and choose Add or double-click on the desired field.
   
   • To remove a field from the query layout, select the field from the Selected Fields selection list and choose Remove.

3 ♦ The fields are listed in the Selected Fields selection list in the order they will be displayed in the query layout (from left to right). To reorder the fields, select a field and choose either the Move Up or Move Down button. Repeat this process until the fields are listed in the order you want them to appear in the query layout.

4 ♦ Choose OK to save your modifications to the query layout.
7.2 Changing Display Field Properties

Field properties determine the way the display fields present data on the screen and in printed reports. Table 7–1 describes these properties.

Table 7–1: Field Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>Determines the display label assigned to the field. Changing the display label for the field does not alter the name of the field stored in the database.</td>
</tr>
<tr>
<td>Format</td>
<td>Determines how the data stored in the field is displayed. For example, display formats indicate how many spaces Results should put in the display, dollar signs, decimal points, or other special characters.</td>
</tr>
<tr>
<td>Hide Repeating Values</td>
<td>Determines whether Results displays repeating values for the fields. (Results displays repeating values for the fields by default.)</td>
</tr>
<tr>
<td>Row</td>
<td>Determines the coordinate location for fields in reports and forms.</td>
</tr>
<tr>
<td>Column</td>
<td>Determines the coordinate location for the field in reports and forms.</td>
</tr>
</tbody>
</table>
Follow these steps to change the properties for one or more display fields:

1 ♦ Choose Field→Properties. The Properties dialog box appears:

2 ♦ Click the down arrow next to the name field to show the list of display fields included in the query, then select the display field you want to modify.

3 ♦ Change the format, label, and repeating values attributes for the field as follows:

   • To change the display format for the field, either type a new format in the Format field or choose the Assistant button.

     If you choose the Assistant button, Results displays the Assistant dialog box for the type of field you are modifying. These types include character, date, decimal, integer, and logical. See the following sections for more information about changing display field formats.

   • To change the display label, select the existing label and type a new label. The new label overwrites the old label.

   • Activate the Hide Repeating Values toggle box.

   • To change the coordinates where a field is displayed in reports and forms, enter a numeric value greater than 1 in the Row and Column fields. The numbers you enter determine the number of rows and columns the field is offset from its current position. One column is equal to one character space and one row is equal to one line, where the line is one character high.
4 ♦ When you are done changing display properties, choose OK in the Properties dialog box to save your changes.

7.2.1 Changing the Format for a Display Field

When you choose the Assistant button in the Properties dialog box, Results displays the Format dialog box for the type of display field you selected. The following sections describe how to change the formats for these field types.

**NOTE:** Any change you make to the display format modifies how the field is displayed.
Changing the display format does not alter how the field is stored in the database.

Changing the Format for a Character Field

Use the Format dialog box to edit character fields:

![Format dialog box]

The format for the field in this example is X(20) where X represents the symbol type for the field and (20) the maximum length of the field. The symbol X means that the field can display any type of character. You can modify both the symbol type and maximum length of the field.
To modify the maximum number of characters the field can display, type a number in the Width field. To modify the symbol type, choose one of the radio buttons listed in Table 7–2, then choose OK.

**Table 7–2: Character Field Properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow Any Character</td>
<td>Displays any type of character, including blank spaces.</td>
</tr>
<tr>
<td>Allow Letters and Numbers Only</td>
<td>Displays only letters and numbers. Blank spaces are not allowed.</td>
</tr>
<tr>
<td>Allow Letters Only</td>
<td>Displays letters only. Blank spaces are not allowed.</td>
</tr>
<tr>
<td>Allow Letters and Convert to Caps</td>
<td>Displays capital letters only. Blank spaces are not allowed.</td>
</tr>
<tr>
<td>Allow Numbers Only</td>
<td>Displays numbers only. Blank spaces are not allowed.</td>
</tr>
</tbody>
</table>

**Changing the Format for a Date Field**

Use the Format dialog box to edit date fields:

![Format dialog box for date fields]
The Format field displays the current format for the field. In this example, the format for the field is 99/99/99. To change the display format for the field, choose one of the radio buttons listed in Table 7–3, then choose OK.

Table 7–3: Date Field Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>99/99/99</td>
<td>Displays the date in mm/dd/yy format.</td>
</tr>
<tr>
<td>99-99.99</td>
<td>Displays the date in mm-dd-yy format.</td>
</tr>
<tr>
<td>99.99.99</td>
<td>Displays the date in mm.dd.yy format.</td>
</tr>
<tr>
<td>99/99/9999</td>
<td>Displays the date in mm/dd/yyyy format.</td>
</tr>
<tr>
<td>99-99-9999</td>
<td>Displays the date in mm-dd-yyyy format.</td>
</tr>
<tr>
<td>99.99.9999</td>
<td>Displays the date in mm.dd/yyyy format.</td>
</tr>
<tr>
<td>999999</td>
<td>Displays the date in mmddyy format.</td>
</tr>
<tr>
<td>99999999</td>
<td>Displays the date in mmddyyyy format.</td>
</tr>
</tbody>
</table>
Changing the Format for a Decimal or Integer Field

Use the Format dialog box to edit decimal and integer fields:

The format for the field in this example is ->,>>,>>9.99, where the dash (-) places a minus sign in front of the number if the number is negative, or a blank in front of the number if the number is positive; the greater than signs (>) are replaced with a digit if that digit is not a leading zero, 9 is replaced with a digit, and the period (.) represents a decimal point.
To modify the default display format for the field, change one or more attributes listed in Table 7–4, then choose OK.

Table 7–4: Decimal and Integer Field Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Number of Digits</td>
<td>Specifies the maximum number of characters the field can display.</td>
</tr>
<tr>
<td>Number of Decimal Places</td>
<td>Specifies the number of decimal places the field can display.</td>
</tr>
<tr>
<td>Use Thousand’s Separator &quot;&quot;,&quot;.&quot;</td>
<td>Displays a comma between the thousands and hundreds columns.</td>
</tr>
<tr>
<td>Suppress Leading Zeros</td>
<td>Does not display leading zeros.</td>
</tr>
<tr>
<td>Show As Zero</td>
<td>Displays leading zeros as zeros.</td>
</tr>
<tr>
<td>Show As Asterisk</td>
<td>Displays leading zeros as asterisks (*).</td>
</tr>
<tr>
<td>Leading Text String:</td>
<td>Specifies the text to display before the number.</td>
</tr>
<tr>
<td>Trailing Text String:</td>
<td>Specifies the text to display after the number.</td>
</tr>
<tr>
<td>Show Leading Sign Always</td>
<td>Always displays a positive (+) or negative (-) sign before the number.</td>
</tr>
<tr>
<td>Show Leading Sign on Negatives Only</td>
<td>Displays a negative (-) sign in front of negative numbers only.</td>
</tr>
<tr>
<td>Show Trailing Sign Always</td>
<td>Always displays a positive (+) or negative (-) sign after the number.</td>
</tr>
<tr>
<td>Show Trailing Sign on Negatives Only</td>
<td>Displays a negative (-) sign after negative numbers only.</td>
</tr>
<tr>
<td>Show Negative Numbers in Parenthesis</td>
<td>Displays negative numbers within a set of parentheses ((())).</td>
</tr>
<tr>
<td>Show Negatives With Trailing 'CR'</td>
<td>Displays the credit symbol (CR) after negative numbers.</td>
</tr>
<tr>
<td>Show Negatives With Trailing 'DB'</td>
<td>Displays the debit symbol (DB) after negative numbers.</td>
</tr>
</tbody>
</table>
Table 7–4: Decimal and Integer Field Properties (2 of 2)

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Negatives With Trailing ‘DR’</td>
<td>Displays the debit symbol (DR) after negative numbers.</td>
</tr>
<tr>
<td>Show Negatives With Trailing ‘cr’</td>
<td>Displays the credit symbol (cr) after negative numbers.</td>
</tr>
<tr>
<td>Show Negatives With Trailing ‘db’</td>
<td>Displays the debit symbol (db) after negative numbers.</td>
</tr>
<tr>
<td>Show Negatives With Trailing ‘dr’</td>
<td>Displays the debit symbol (dr) after negative numbers.</td>
</tr>
<tr>
<td>Allow positive numbers only</td>
<td>Displays positive numbers only.</td>
</tr>
</tbody>
</table>

Changing the Format for a Logical Field

Use the Format dialog box to edit logical fields:

Logical fields can have one of two possible values: TRUE or FALSE. The format field shows the terms used to display these values. To change these terms, type a new term in the Display This When TRUE and Display This When FALSE fields, then choose OK.
This appendix describes the standard menu options. If your application was modified, the menu options you have might not be the same as these:

- Query Menu
- Table Menu
- Field Menu
- Data Menu
- Options Menu
- View Menu
- Help Menu
A.1 Query Menu

The Query menu manipulates queries and exits Results. Table A–1 describes the query menu.

Table A–1: Query Menu

<table>
<thead>
<tr>
<th>Query</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Creates a new query.</td>
</tr>
<tr>
<td>Save</td>
<td>Saves a query.</td>
</tr>
<tr>
<td>Save As...</td>
<td>Names and saves a query.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes a query without exiting Results.</td>
</tr>
<tr>
<td>Delete...</td>
<td>Deletes one or more queries.</td>
</tr>
<tr>
<td>Generate...</td>
<td>Generates 4GL code for the query. (Might be available to the system administrator only.)</td>
</tr>
<tr>
<td>Print</td>
<td>Prints a query. You can also use the Print option to save the query to the Clipboard or to a file.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>Displays how the printed document will look.</td>
</tr>
<tr>
<td>Site Admin</td>
<td>Sets printer options, access limitations, and define table relationships. (Might be available to the system administrator only.)</td>
</tr>
<tr>
<td>Customize</td>
<td>Modifies the Results environment. (Might be available to the system administrator only.)</td>
</tr>
<tr>
<td>Exit</td>
<td>Exits the Results application.</td>
</tr>
<tr>
<td>Add/Remove Fields...</td>
<td>Adds and removes display fields from the query view.</td>
</tr>
<tr>
<td>Add Calculated Field...</td>
<td>Creates a variety of calculated fields to display in the query view.</td>
</tr>
<tr>
<td>Aggregates...</td>
<td>Creates aggregates for the current report.</td>
</tr>
<tr>
<td>Properties</td>
<td>Modifies field names, labels, data formats, and coordinates for the display fields in the query view.</td>
</tr>
</tbody>
</table>
A.2 Table Menu

The Table menu manipulates tables. Table A–2 describes the menu that appears when you select this option.

Table A–2: Table Menu

<table>
<thead>
<tr>
<th>Table</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add/Remove Tables...</td>
<td>Adds and removes tables from the open query.</td>
</tr>
<tr>
<td>Relationship Types...</td>
<td>Defines partial or complete relationships among tables in the query.</td>
</tr>
</tbody>
</table>

A.3 Field Menu

The Field menu creates and manipulates fields. Table A–3 describes the menu that appears when you select this option.

Table A–3: Field Menu

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add/Remove Fields...</td>
<td>Adds and removes display fields from the query view.</td>
</tr>
<tr>
<td>Add Calculated Field...</td>
<td>Creates a variety of calculated fields to display in the query view.</td>
</tr>
<tr>
<td>Aggregates...</td>
<td>Creates aggregates for the current report.</td>
</tr>
<tr>
<td>Properties</td>
<td>Modifies field names, labels, data formats, and coordinates for the display fields in the query view.</td>
</tr>
</tbody>
</table>
A.4 Data Menu

The Data menu manipulates data. Table A–4 describes the menu that appears when you select this option.

Table A–4: Data Menu

<table>
<thead>
<tr>
<th>Data</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection...</td>
<td>Defines the selection criteria Results uses to retrieve records from the database.</td>
</tr>
<tr>
<td>Re-ask Questions...</td>
<td>Prompts you to redefine the data selection criteria in the Form and Browse views.</td>
</tr>
<tr>
<td>Sort Ordering...</td>
<td>Determines the order in which Results retrieves records from the database.</td>
</tr>
<tr>
<td>Governor...</td>
<td>Limits the number of records retrieved from the database.</td>
</tr>
</tbody>
</table>
A.5 Options Menu

The options menu manipulates query and page information. Table A–5 describes the menu that appears when you select this option.

Table A–5: Options Menu

<table>
<thead>
<tr>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Query Information...</td>
<td>Displays a list containing the tables included in the query, the display fields used, the sort order for the query, and if you either printed or viewed a report through print preview, the amount of time it took to run the query, and the connected databases.</td>
</tr>
<tr>
<td>Headers and Footers..</td>
<td>Creates report headers, footers, cover pages, and final pages.</td>
</tr>
<tr>
<td>Master-Detail...</td>
<td>Sets a break point between the tables used in the Master and Detail sections of a query.</td>
</tr>
<tr>
<td>Frame Properties...</td>
<td>Changes a frames location in the query window and its read-only status. For Browse views, frame properties changes the number of rows displayed in the browse at one time.</td>
</tr>
<tr>
<td>Totals Only Summary..</td>
<td>Creates a Totals Only section in a report.</td>
</tr>
<tr>
<td>Standard Page...</td>
<td>Selects a predefined label type on which to print the label.</td>
</tr>
<tr>
<td>Customer Page...</td>
<td>Defines a non-standard page size on which to print the report.</td>
</tr>
<tr>
<td>Page Break...</td>
<td>Places a page break in the printed report.</td>
</tr>
<tr>
<td>Standard Label...</td>
<td>Selects a predefined label type on which to print the label.</td>
</tr>
<tr>
<td>Custom Label...</td>
<td>Defines a nonstandard label type on which to print the label.</td>
</tr>
<tr>
<td>Standard Export...</td>
<td>Selects an export data type to export a query to an ASCII file.</td>
</tr>
<tr>
<td>Custom Export...</td>
<td>Defines nonstandard field delimiters, field separators, record initialization strings, and record termination strings that Results uses to export a query to an ASCII file.</td>
</tr>
</tbody>
</table>
A.6 View Menu

The View menu control in which view Results displays the data and manipulate the screen layout. Table A–6 describes the menu that appears when you select this option.

Table A–6: View Menu

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>As Browse</td>
<td>Lists records on-screen in a tabular form similar to a spreadsheet.</td>
</tr>
<tr>
<td>As Report</td>
<td>Creates reports for printing.</td>
</tr>
<tr>
<td>As Form</td>
<td>Views, updates, adds, and deletes records in the database.</td>
</tr>
<tr>
<td>As Label</td>
<td>Uses the Labels view to create and print labels.</td>
</tr>
<tr>
<td>As Export</td>
<td>Exports queries to ASCII files that can be incorporated into other applications.</td>
</tr>
<tr>
<td>Tool Bar</td>
<td>Displays or hides the tool bar and criteria field.</td>
</tr>
<tr>
<td>Status Bar</td>
<td>Displays or hides the status bar.</td>
</tr>
</tbody>
</table>
A.7 Help Menu

The Help menu provides help information. Table A–7 describes the menu that appears when you select this option.

Table A–7: Help Menu

<table>
<thead>
<tr>
<th>Help</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help Topics</td>
<td>Choose this option to access the main table of contents, the index, and the search engine for help information about the specific tool.</td>
</tr>
<tr>
<td>Messages</td>
<td>Choose this option to quickly search for information about Progress and operating system error messages. In the Messages dialog box, enter the message number to display the description.</td>
</tr>
<tr>
<td>Recent Messages</td>
<td>Choose this option to display the most recent Progress message and its description. You can scroll backwards through all messages since the beginning of your session.</td>
</tr>
<tr>
<td>About Results</td>
<td>Choose this option to display the version of Progress Results, copyright date, and system and memory information.</td>
</tr>
</tbody>
</table>
Comparison Operators

You use comparison operators within WHERE clauses to refine the selection criteria for a query. Table B-1 in this appendix describes the available comparison operators. See the “Creating Filters” section in Chapter 5, “Changing the Query Selection Criteria,” for more information about creating WHERE clauses.
### Table B–1: Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equality selects records where the value of the tested field is equal to the specified value.</td>
<td><strong>State = &quot;Massachusetts&quot;</strong>&lt;br&gt;Selects all the customers from Massachusetts.</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Inequality selects records where the value of the tested field is different to the specified value.</td>
<td><strong>Balance&lt;&gt; 0</strong>&lt;br&gt;Selects all the customers with a credit balance not equal to $.00.</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less Than selects records where the value of the tested field is smaller than the specified value.</td>
<td><strong>Cust-Num &lt; 50</strong>&lt;br&gt;Selects all the customers 1 through 49.</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater Than selects records where the value of the tested field is larger than the specified value.</td>
<td><strong>Balance &gt; 0</strong>&lt;br&gt;Selects all the records with a balance of more than $.00.</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less Than or Equal To selects records where the value of the tested field is less than or equal to the specified value.</td>
<td><strong>Amount &lt;= 1000.00</strong>&lt;br&gt;Selects all the invoices that total less than or equal $1000.00.</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater Than or Equal To selects records where the value of the tested field is greater than or equal to the specified value.</td>
<td><strong>Invoice-Date &gt;= 05/27/94</strong>&lt;br&gt;Selects all the invoices dated 05/27/94 or later.</td>
</tr>
<tr>
<td>Begins</td>
<td>Selects records where the value of the tested field begins with a specific character.</td>
<td><strong>Name Begins &quot;J&quot;</strong>&lt;br&gt;Selects all the customers that start with the letter “J”.</td>
</tr>
<tr>
<td>Matches</td>
<td>Selects records where the value of the tested field matches one or more characters. Use “wildcard” characters to extend the range of pattern matching capabilities. Use an asterisk (*) to match any group of characters and a period (.) to match any single character in the specified position.</td>
<td><strong>Name Matches &quot;Urpon Frisbee&quot;</strong>&lt;br&gt;Selects all the customer records that match the name “Urpon Frisbee.”&lt;br&gt;<strong>Name Matches <em>and</em></strong>&lt;br&gt;Selects all the customer records that contain the substring “and.”&lt;br&gt;<strong>Postal-Code Matches 02.10</strong>&lt;br&gt;Selects records with the Postal-Code field matching 02010, 02110, 02210, 02310, 02410, 02510, 02610, 02710, 02810, and 02910.</td>
</tr>
</tbody>
</table>
Comparison Operators

Table B–1: Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
</table>
| Contains | Selects records where a particular field contains a specific word. Use an asterisk (*) at the end of a word fragment to extend the range of pattern matching capabilities for the word. | Comment Contains "credit"
Selects those records where the Comment field contains the word “credit.”
Comment Contains "cred*"
Selects those records where the Comment field contains a word that begins with “cred”. |
| Range    | Selects records where the value of the tested field falls within a specified range. Use the Inclusive checkbox to set whether or not the range is to be considered inclusive. If the range is inclusive, it contains the beginning and ending values. | Cust-Num Range 10 20 Inclusive
Selects the records for customer numbers 10 through 20.
Cust-Num Range 15 25 Exclusive
Selects the records for customer numbers 16 through 24. |
Glossary

Aggregate Field
A field that calculates the value of a column of fields. If break groups are used, calculates the value of a column of fields for each break group. Results calculates the following aggregates: total, count, minimum, maximum, and average.

Array
A field or variable with multiple elements. Each element in an array has the same data type.

Ask At Run Time
A type of selection criteria in which part of the selection criteria is not known until run time.

Average
An aggregate that calculates the average value (sum of values divided by the number of records) in a column of data, either by break group or for the entire column.

Break Group
A set of records that have a common value in a certain database field. Break groups are used in reports to display table and record relationships.

Browse View
A Results view that displays a query on your computer screen. The Browse view lists records online in a tabular format similar to a spreadsheet.

Calculated Field
A field you create within Results to help you analyze the data in the query. Calculated fields are display fields only.
Comparison Operator
A symbol or word used to make comparisons. For example, LESS THAN (<), Equals (=), or GREATER THAN (>).

Complete Relationship
A type of relationship or join. When used in a query that accesses two or more tables, a complete relationship instructs Results to access all the records in the first table whether or not they have related records in the second table. See also Partial relationship.

Composite Record
A record that contain fields from more than one table.

Compound Index
An index that is based on the value of two or more fields. See also Index.

Constant
A value that does not change.

Count Aggregate
An aggregate field that calculates the number of records in a column of data, either by break group or for the entire report.

Cover Page
Text that appears on the very first page of a report as a separate page, before the first data record is processed. The cover page does not contain any report data.

Data
The information stored in a database.

Data Governor
A feature that restricts the number of records reported to the user. The data Governor is available for Report, Label, and Export views.

Data Selection
The process of defining selection criteria for a query.

Database
A collection of data organized in logically related tables or fields that can be accessed or retrieved. See also Data.
Display Field
A field in the query that is displayed in the query views as opposed to a field in the query that is not displayed in the query views.

Export View
A Results view that formats records to export to other applications.

Expression
A combination of constants, variables, operations, and parentheses used to perform a calculation. An expression can consist of anything from a single constant or variable to a complicated arrangement of operators and functions that fit into a single clause.

Field
A specific item of information. A record typically contains several related fields. See also Record.

Field Delimiter
An ASCII, decimal, hexadecimal, or octal code that marks the start and end of each field for exporting data to other applications.

Field Separator
An ASCII, decimal, hexadecimal, or octal code that distinguishes one field from the next for exporting data to other applications.

Final Page
Text that appears on the very last page of a report, after all the data records have been processed. The final page does not contain any report data.

Footer
Text that appears at the bottom of every page.

Form View
A Results view that displays a query on your computer screen. The Form view allows you to view, update, add, and delete records in the database.

Frame
An area within a window where Results displays the contents of a query. A window can contain either one or two frames.

Function
A prepackaged solution to a task that can be used in an expression.
Go-to Link

In online help, a hypertext link that displays a new help topic. A go-to link is a word or phrase set apart from the surrounding text by a solid underline. See also Hypertext Link.

Header

Text that appears at the top of every report page.

Help Topic

In on-line help, displays information about one thing, such as a particular window or dialog box.

Hide Repeating Values

A function that suppresses display of repeating or duplicate field values.

Hypertext Link

In online help, an underlined word or phrase that accesses related information. There are two types of hypertext links: pop-up links and go-to links. To display the information associated with a hypertext link, click the underlined topic. See also Pop-up Link and Go-to Link.

Index

A list that contains a value for each record in a table. Indexes let you sort, process, and search for records in a table quickly and efficiently.

Label View

A Results view that formats and prints records in a variety of label formats, including mail and inventory labels.

Many-to-many Relationship

A table relationship that occurs when many records in one table can relate to many records in a second table; and many records in the second table can relate to many records in the first table. See also Table Relationship.

Master-Detail

A feature whereby a multi-table, single-selection report is split into two sections. Master-Detail is especially useful for eliminating duplicate, repeating values in a report. See also Hide Repeating Values.

Minimum

An aggregate field that calculates the smallest value in a column of data, either by break group or for the entire report.
Maximum

An aggregate field that calculates the largest value in a column of data, either by break group or for an entire report.

One-to-many Relationship

A table relationship that occurs when a record in one table can relate to many records in another table. See also Table Relationship.

One-to-one Relationship

A table relationship that occurs when a record in one table can relate to only one record in another table. See also Table Relationship.

Online Help

A feature that lets you get information about the Results application from within Results. Online help contains descriptions of the Results windows and dialog boxes and explanations of how to use the features available within Results.

Partial Relationship

A type of relationship or join. In a query that accesses two or more tables, a partial relationship instructs Results to access only those records in the first table that have related records in the second table. See also Complete Relationship.

Pop-up Link

In online help, a hypertext link that displays a definition. A pop-up link is a word or phrase set apart from the surrounding text by a dotted underline. See also Hypertext Link.

Print Preview

A window that shows the output from running a report or exporting a data file.

Query

A set of instructions that tells Results to locate data in one or more tables in your database.

Query Configuration

A file that contains database and Results application settings used by all Results users. The query configuration file has an extension of .qc7.

Query Directory

A file that contains a list of queries for each user. The query directory field has an extension of .qd7.
Query Example

A dialog box that prompts the user for data selection values in-situ, that is directly in the field fill-in involved in the data selection.

Record

A collection of items of information called fields. A table typically contains many records that contain similar information.

Record End

An ASCII, decimal, hexadecimal, or octal code that marks the end of each record for exporting data to other applications.

Record Start

An ASCII, decimal, hexadecimal, or octal code that marks the start of each record for exporting data to other applications.

Report View

A Results view that creates multi-line and master-detail reports for printing. Provides calculated values and totals for thorough data analysis.

Selection Criteria

A user-defined criteria that determines which records the query returns from the database and the order in which it returns them. The criteria for the query is displayed in the Criteria field in the query window.

Self-join

A table relationship in which a table is joined to itself. See also Alias.

Simple Index

An index that is based on the value of one field. See also Index.

Sort Order

A user-defined order that determines the order in which Results retrieves records from the database.

Status Bar

The horizontal line at the bottom of the Results window that contains informational messages about the current status of Results, including the database you are connected to and the query view you are using.

Subexpression

An expression within an expression.
Glossary

Subtotal
An aggregate field that calculates a column of fields for each break group. See also Total.

Table
A collection of related records organized into rows and columns. See also Record.

Table Relationship
Determines the set of records returned in a query containing two or more tables. There are two types of table relationships: complete or partial. See also Complete Relationship and Partial Relationship.

Tool bar
A linear series of buttons that allows the user to quickly perform a function. The most commonly used functions or features are usually represented on the tool bar.

Total
An aggregate field that calculates an entire column of fields whether or not the fields are displayed within break groups. Also, a specific type of aggregate that sums the value of each field in a column. See also Subtotal.

Totals Only Summary
A Report and Export view setting in which numeric data values are summarized by break group, and only these summaries are displayed.

View
A method for displaying and processing the data retrieved by a query. Results provides you with the following views: Browse, Report, Form, Labels, and Export. Depending on the view you use, you can scroll through the data, update the data, generate reports and mailing labels, or export the data to other applications.

WHERE Clause
A phrase that lets you limit the set of data returned by a query.
Index

A

Adding
  display fields 7–2
  tables to a query 5–2
ADE, See Application Development Environment
Adjusting report dimensions 4–19
Aggregate fields
  average 6–36
  count 6–36
  creating 6–36, 6–40
  maximum 6–36
  minimum 6–36
  subtotal 6–38
  total 6–36, 6–37
Analyzing data 6–1
Application Development Environment
desktop 2–4
Arrays 6–6, 6–11
ASCII files
  generating 4–27
Ask At Runtime
dialog box 5–15
toggle box 5–12

B

Bars
  scroll 3–12
Bold typeface
  as typographical convention xi
Break groups 5–8, 6–38
Browse views 3–2, 4–2
  described 2–2
  frames 4–4
  navigating through records 4–3

C

Calculated fields
  counter 6–6, 6–10
  creating 6–7
  date function 6–7, 6–25
  described 6–5
  logical function 6–7, 6–29
  lookup 6–6, 6–12
  math 6–6, 6–15
  numeric function 6–7, 6–21
  percent of total 6–6, 6–8
  removing 6–36
  renaming 6–34
running total 6–6, 6–9
stacked array 6–6, 6–11
string function 6–6, 6–18

Changing
display field properties 7–3
relationships 5–4

Character fields 7–5

Closing queries 3–10

Comparison operators B–1

Complete relationships 3–8
changing 5–4
described 3–8
effect on sort order 5–4

Complete table relationships, See Complete relationships

Composite records 3–6, 6–4

Compound indexes 1–6

Connecting databases 2–5

Context-sensitive help 2–7

Copying records 4–9

Creating
aggregate fields 6–36, 6–40
ASCII files 4–29
calculated fields 6–5, 6–7
labels 4–20
queries 3–2
records 4–9
WHERE clauses 5–10

Data menu A–4

Data selection 5–11
creating WHERE clauses 5–10
removing WHERE clauses 5–16
setting at runtime 5–15

Databases
connecting 2–5
described 1–2
indexes, See Indexes
modifying 4–7
tables, See Tables

Date fields 7–6

Dates
calculated fields 6–7, 6–25

Decimal fields 7–8

Defaults
queries 3–7

Deleting
queries 3–13
records 4–10

Detail section 6–2

Display fields
adding 7–2
changing labels 4–13
changing properties 7–3
changing the order 7–2
character 7–5
creating aggregate fields 6–36
creating calculated 6–5
date 7–6
decimal 7–8
described 3–3
format 4–13, 7–5
integer 7–8
label 4–13
logical 7–10
modifying 7–1
numeric 7–8
rearranging in form view 4–10
removing 7–2
removing calculated 6–36

Index–2
E

Error messages
displaying descriptions xv

Exiting
online help 2–9
RESULTS 2–10

Export types
modifying 4–30
selecting 4–27

Export views 3–2, 4–26
described 2–2
modifying export types 4–30
selecting export types 4–27

Expressions
calculated fields 6–6, 6–15

F

Field menu A–3

Fields
See also Display fields
aggregate, See Aggregate fields
calculated, See Calculated fields
calculated fields 6–6, 6–15
character 7–5
database
structure 1–5
date 7–6
decimal 7–8
described 1–5
display, See Display fields
integer 7–8
logical 7–10
rearranging 4–10
selecting for queries 3–5
values 6–6, 6–12

Files
ASCII 4–27

Filters 5–10

Footers 4–14

Form views 3–2, 4–6
described 2–2
frames 4–11
modifying databases 4–7
navigating through records 4–7

Formats for display fields 7–5

Frames
browse views 4–4, 4–5
form view 4–11
changing properties 4–12

G

Generating ASCII files 4–27
Go-to links 2–9

H

Headers 4–14

Help
accessing 2–7 to 2–9
menu A–7
Progress messages xv
See also Online help

Help topics 2–7

Hypertext links 2–7, 2–8

I

Indexes 3–7
compound 1–6
described 1–6
simple 1–6

Inner joins, See Relationships, partial

Integer fields 7–8

Italic typeface
as typographical convention xi
J
Joins, See Relationships

K
Keystrokes xi

L
Label types
   reformatting 4–24
   selecting 4–24
Label views 3–2, 4–20
   described 2–2
   reformatting labels 4–24
   selecting label types 4–24
Labels
   creating 4–20
   printing 4–26
Logical fields 7–10
Logicals
   calculated fields 6–7, 6–29

M
Manual
   syntax notation xii
Manual, organization of ix
Many-to-many relationships 1–9
Master sections 6–2
Menu bar 2–6
Menus A–1
Messages
   displaying descriptions xv
Modifying

Index–4
display fields 7–1
export types 4–30
Monospaced typeface
   as typographical convention xi

N
Navigation buttons
   print preview 3–12
Numeric fields 7–8

O
One-to-many relationships 1–8
One-to-many table relationships 3–6
One-to-one relationships 1–8
Online help
   described 2–7 to 2–9
   exiting 2–9
   go-to links 2–9
   help topics 2–7
   hypertext links 2–7
   pop-up links 2–8
   using 2–7
Opening queries 3–10
Operators B–1
Options menu A–5
Order, sort
   See Sort order
Outer joins
   See Relationships, partial

P
Page size 4–19
Pages
   cover 4–14
Index

final 4–14
footers 4–14
headers 4–14
sizes 4–18, 4–19

Partial relationships 3–7, 5–4

Pop-up links 2–8

Print preview 3–11

Printing
labels 4–26
queries 3–11
reports 4–20

Program groups
starting RESULTS 2–3

Properties
display fields 7–3
frames 4–5
form view 4–12

Q

Queries 3–1
adding tables 5–2
closing 3–10
creating 3–2
data selection 5–11
defaults 3–7
deleting 3–13
described 1–7
frames, See Frames
getting information 3–11
opening 3–10
printing 3–11
relationships 3–7
removing tables 5–2
saving 3–9
selection criteria 5–1
views 3–2

Query By Example 5–16
creating WHERE clauses 5–16
removing WHERE clauses 5–18

Query directory (.qd7) 3–9

Query menu A–2

Query selection criteria
changing 5–1

R

Rearranging display fields 4–10

Records 1–2

composing 3–6, 6–4
copying 4–9
creating 4–9
deleting 4–10
described 1–5
modifying 4–7
navigating
form views 4–3, 4–7
sorting 5–6
updating 4–8

Reformatting labels 4–24

Relationships 3–6, 5–4
changing 5–4
complete 3–8
described 1–7
many-to-many 1–9
one-to-many 1–8
one-to-one 1–8
partial 3–7
selecting for queries 3–4
types 1–8
defaults 3–7

Removing
calculated fields 6–36
display fields 7–2
tables from a query 5–2
WHERE clauses
created through data selection 5–16
created through Query By Example 5–18

Renaming calculated fields 6–34

Report views 3–2, 4–13
described 2–2

Index–5
Index—6

Progress Results User’s Guide for Windows

Reports
  adjusting dimensions 4–19
  cover pages 4–14
  final pages 4–14
  footers 4–14
  headers 4–14
  printing 4–20
  selecting page sizes 4–18

RESULTS 2–1
  described 2–2
  exiting 2–10
  main window 2–6
  starting 2–3
  versions
    modified 2–2

S

Saving queries 3–9

Scroll bars 3–12

Selecting
  export types 4–27
  label types 4–24
  page sizes, reports 4–18

Setting data selection at run time 5–15

Simple indexes 1–6

Sort order
  break groups 5–8
  defaults 3–7
  specifying 5–8

Sorting
  records 5–6

Starting RESULTS 2–3

Status bars 2–6, 3–6

Strings
  calculated fields 6–6, 6–18
  modifying 4–31

Switching query views 4–2

Syntax notation xii

T

Table menu A–3

Table relationships 3–6

  See also Relationships

Tables
  adding 5–2
  removing 5–2
  selecting for queries 3–4
  structure 1–4

Tool bar 2–6

Totals
  aggregate fields 6–37
  running 6–6, 6–9
  totals only summary 6–41

Typographical conventions xi

U

Updating records 4–8

Using
  print preview 3–11

V

Versions, See RESULTS

View menu A–6

Views
  browse 4–2, 4–3
  described 2–2
  export 4–26
    modifying export types 4–30
    selecting export types 4–27
    using 4–26
  form 4–6
    modifying databases 4–7
    navigating through records 4–7
Index

label 4–20
  reformatting labels 4–24
  selecting label types 4–24
report 4–13
  formatting 4–14
  printing 4–20
  selecting page size 4–18
switching 4–2

W

WHERE clause
  creating 5–10
  removing 5–16, 5–18

Index–7